Open Autolocation has stopped working

Discussion in 'AutoLocation' started by Benjie, Mar 15, 2017.

  1. Benjie

    Benjie New Member

    Joined:
    Mar 15, 2017
    Messages:
    5
    Likes Received:
    0
    I have a Tasker profile that starts the location monitor when the phone is unlocked, and it stopped working this morning after a restart. I opened Autolocation and tried to start the monitor from there and discovered that nothing happens when I click on Start Monitor. I also found that I can't toggle the monitor on Activities or Geofences, either. The Activities and Geofences monitors were on before I rebooted but couldn't be turned off, and now all 3 monitors are off and can't be turned on. I have rebooted my phone, cleared the app cache, cleared the app data, and re-installed the app with no success. I've also tried it with AutoApps installed and uninstalled, and I've cleared the app data on the unlock key.
    In Tasker, when I run the task, I get the following output:
    13.00.38/ActionArgBundle key: SmallestDisplacement: replace <null> String value with null
    13.00.38/ActionArgBundle key: ExpirationDuration: replace <null> String value with null
    13.00.38/ActionArgBundle key: NumberOfUpdates: replace <null> String value with null
    13.00.38/ActionArgBundle key: Interval: replace <null> String value with null
    13.00.38/ActionArgBundle AutoLocation Location: ExpirationDuration: ignored replacement specified for null value
    13.00.38/ActionArgBundle AutoLocation Location: Interval: ignored replacement specified for null value
    13.00.38/ActionArgBundle AutoLocation Location: NumberOfUpdates: ignored replacement specified for null value
    13.00.38/ActionArgBundle AutoLocation Location: SmallestDisplacement: ignored replacement specified for null value
    13.00.38/E FIRE PLUGIN: AutoLocation Location / com.twofortyfouram.locale.intent.action.FIRE_SETTING: 12 bundle keys
    13.00.38/E AutoLocation Location: plugin comp: com.joaomgcd.autolocation/com.joaomgcd.autolocation.broadcastreceiver.BroadcastReceiverRequestActivityReport
    13.00.38/E add wait type Plugin1 time 1
    13.00.38/E add wait type Plugin1 done
    13.00.38/E add wait task
    13.00.39/E Error: null​
    If I select Continue After Error and flash %errmsg, it returns "timeout" when I run the task. If I change the timeout on the action to a greater value like 60, it still times out.
    In the AutoLocation logs with System Logs checked and all of the options checked in Configure Logs, I'm not getting any entries except "Lite from cache: false".
    How can I fix this issue? I'm out of ideas.
    My phone is an unrooted Verizon S7 Edge SM-G935V running Android 7.0. build number G935VVRU4BQA2.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    3,912
    Likes Received:
    368
    Hi there. What action returns that error exactly? Thanks in advance
     
  3. Benjie

    Benjie New Member

    Joined:
    Mar 15, 2017
    Messages:
    5
    Likes Received:
    0
    Selecting the Autolocation task and then location with location monitor set to start and the location report name set. I also have the update type set to balanced, but I've changed that value with no results.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    3,912
    Likes Received:
    368
    Thanks again. Just to be sure, does AutoLocation have the location permission on your device? thanks
     
  5. Benjie

    Benjie New Member

    Joined:
    Mar 15, 2017
    Messages:
    5
    Likes Received:
    0
    Yes, it has the location permission.
    After the original post, it quickly flashed "Monitor started" and "Monitor stopped" many times (I can't remember if that was the exact text, it was the flash alert you would normally get if you toggle one of the monitors. Afterward, I was able to toggle the monitors. Later that day before I could post that it was working now, the toggles stopped working again.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    3,912
    Likes Received:
    368
    That's very unusual behaviour.. seems to be something specific to your system... Do you maybe have an app killing others in the background on your system? thanks
     
  7. Benjie

    Benjie New Member

    Joined:
    Mar 15, 2017
    Messages:
    5
    Likes Received:
    0
    I have Greenify installed, but AutoLocation isn't hibernated. Otherwise, I don't have any task killers. This wasn't a problem until I updated to Nougat.
     
  8. Benjie

    Benjie New Member

    Joined:
    Mar 15, 2017
    Messages:
    5
    Likes Received:
    0
    I'm going to be doing a factory reset in the next couple of days since I have a couple of other problems since the update. I'll update after that.
     
: autolocation

Share This Page