Open Cellular toggle?

Discussion in 'AutoWear' started by Cr0wstuf, Nov 9, 2017.

  1. Cr0wstuf

    Cr0wstuf New Member

    Joined:
    Nov 9, 2017
    Messages:
    7
    Likes Received:
    0
    I have'nt been able to find info on this anywhere. I just picked up a ZTE Quartz with cellular and would really like it if I could have cellular toggle when bluetooth is connected/disconnected from my phone. If this feature is impossible, is there any chance of it getting added in the future? Thank you!
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    5,269
    Likes Received:
    482
  3. Cr0wstuf

    Cr0wstuf New Member

    Joined:
    Nov 9, 2017
    Messages:
    7
    Likes Received:
    0
    Alrighty. I was able to find the setting on the watch. It is a global setting, 'cell_on=0'. When enabled obviously it turns to 1. I am having a really hard time trying to figure out how to configure AutoWear, AutoTools and Tasker to work together to enable/disable the watches cellular when connecting/disconnecting from the phones. bluetooth. Is there a tutorial you can recommend from this point? I greatly appreciate the help.

    These apps are great by the way. With AutoTools I can now enable location within select apps and disable when closing... which is great because my battery life on the Galaxy S8 is terrible :(
     
    Last edited: Nov 10, 2017
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    5,269
    Likes Received:
    482
    You don't really need AutoTools for it :) You should be able to create a secure setting in AutoWear and set the command to apply to the Disconnected From Phone pre-defined command. Does that work for you?
     
    Cr0wstuf likes this.
  5. Cr0wstuf

    Cr0wstuf New Member

    Joined:
    Nov 9, 2017
    Messages:
    7
    Likes Received:
    0
    Awesome! I configured it correctly I believe. I created two entries to disable the cellular when Bluetooth connects and a second the enable when Bluetooth disconnects. I can tap on them and click 'Apply now's and it works! But it doesn't happen automatically as I disable the Bluetooth on either phone or watch and it doesn't happen when I leave range of my phone. Did I do something wrong?
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    5,269
    Likes Received:
    482
    Can you please show me how you configured those? Thanks!
     
  7. Cr0wstuf

    Cr0wstuf New Member

    Joined:
    Nov 9, 2017
    Messages:
    7
    Likes Received:
    0
    Secure Settings - DisableCell
    Setting Type: Global
    Name: cell_on
    Input Type: Toggle
    Value: 2
    Apply Now: true
    Command to apply: &CONNECTED&
    Name: DisableCell

    Secure Settings - EnableCell
    Setting Type: Global
    Name: cell_on
    Input Type: Toggle
    Value: 1
    Apply Now: true
    Command to apply: &DISCONNECTED&
    Name: EnableCell
     
  8. Cr0wstuf

    Cr0wstuf New Member

    Joined:
    Nov 9, 2017
    Messages:
    7
    Likes Received:
    0
    I just setup notifications for when my phone disconnects and reconnects via Bluetooth and I they show up on the watch when I save the configs on the phone but they don't run while disconnecting/reconnecting.
     
  9. eDs

    eDs New Member

    Joined:
    Jan 10, 2016
    Messages:
    10
    Likes Received:
    0
    I think the problem is that when BT disconnects then tasker cant run the task on the wear device so it cant turn 3g on. I cant figure out how to execute the task on android wear rather than on the phone
     
  10. Cr0wstuf

    Cr0wstuf New Member

    Joined:
    Nov 9, 2017
    Messages:
    7
    Likes Received:
    0
    I think you may be right. I've tried many different configurations of tasks dependent on when the phone connects/disconnects via Bluetooth and the actions/alerts are very shotty. Not sure if this is just a natural limitation or not as I'm new to autoapps.
     
  11. eDs

    eDs New Member

    Joined:
    Jan 10, 2016
    Messages:
    10
    Likes Received:
    0
    Ok so it works differently than what we thought. What happens is if you use the &CONNECTED& or &DISCONNECTED& settings for Wear it transfers it to the watch and runs from the watch and isnt pushed down from Tasker. IE if you created the tasks to turn 3g on and another for 3g off it should run from the watch only when the watch goes into a disconnected state. The problem is that with watches with Wifi and 3g it still stays connected and doesnt pick up a disconnected state and thats why the tasks don run. It will have to be changed or added that it should check for BT disconnected state only and it seems like its not possible at this moment. So the autowear up should have different checks for disconnected state ie BT or wifi or celular then we can get this to work
     
  12. Cr0wstuf

    Cr0wstuf New Member

    Joined:
    Nov 9, 2017
    Messages:
    7
    Likes Received:
    0
    I though about it and realized that I've only ever tested this while disconnected from wifi. So I turned wifi and cellular off in settings and walked out of range of my phone. The Wifi turned back on, cellular didn't. I could've grabbed the wrong global setting but I don't think so because when I test the action from the phone app it does exactly what's needed. Seems like it's an Android problem rather than autowear.
     
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    5,269
    Likes Received:
    482
    yeah, unfortunately I can't get it to send the disconnected event to AutoWear anymore :(
     
  14. eDs

    eDs New Member

    Joined:
    Jan 10, 2016
    Messages:
    10
    Likes Received:
    0
    Jao can you please try again with AW 2.6?
     
  15. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    5,269
    Likes Received:
    482
    Ok, thanks. I'll try.
     
  16. eDs

    eDs New Member

    Joined:
    Jan 10, 2016
    Messages:
    10
    Likes Received:
    0
: cellular

Share This Page