AutoTools Disable and enable your lock screen at will (No Root!)

Learn how you can make your phone lock when the screen turns off only when you're not at home

  1. venky

    venky New Member

    Joined:
    Dec 28, 2017
    Messages:
    1
    Likes Received:
    0
    joaomgcd,
    I purchased AutoTools and I followed instructions to disable and enable lock screen. This is is what is happening.
    1. When I am away from home (or my wifi is disconnected), my phone locks immediately. So this part is working, no problem.
    2. When my phone connects to my wifi, my phone does not unlock automatically. I have to unlock it the first time and then it stays unlocked for the duration of seconds I configured in AutoTools. This part of unlocking automatically is not happening. I purchased AutoTools for this specific purpose i.e., to lock and unlock automatically. If I have to first unlock it then I can use my phone settings to do it, I don't need AutoTools. How can I make my phone unlock automatically after it connects to my wifi? Thanks!
     
  2. Stupifier

    Stupifier Member

    Joined:
    Mar 10, 2015
    Messages:
    140
    Likes Received:
    6
    I'm pretty sure it is working as it should. Before engaging the Automatic Unlock, you have to first Unlock your phone (one time). Otherwise, I think the feature would be a security risk
     
    GXG.O likes this.
  3. santinabella

    santinabella New Member

    Joined:
    Jan 19, 2018
    Messages:
    2
    Likes Received:
    0
    Good afternoon joaomgcd,
    I'm having an issue with this profile. After following the steps in the first post, the profile works for a period of time, but the locking and unlocking function seems to be random. Sometimes at home, the screen locks; sometimes when I'm away from my wifi, the screen is unlocked. Below is my Tasker set up. Any clues to what might be wrong with my profile? Thanks for your help!

    Profile: PIN Lock (21)
    State: Wifi Connected [ SSID:<my SSID is specified here> MAC:* IP:* Active:Yes ]
    Enter: Unlock At Home (27)
    A1: AutoTools Secure Settings [ Configuration:Automatic Lock: 86400 Timeout (Seconds):60 ]

    Exit: Lock While Away (37)
    A1: AutoTools Secure Settings [ Configuration:Automatic Lock: 0 Timeout (Seconds):60 ]
     
  4. Drose6102

    Drose6102 New Member

    Joined:
    Jan 22, 2018
    Messages:
    1
    Likes Received:
    0
    Thank you for this, I couldn't get the profile to work consistently.
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    6,545
    Likes Received:
    580
    @santinabella can you try using the Tasker System Lock action in the away task? That will make sure that the device is locked right away. Thanks in advance!
     
  6. Stupifier

    Stupifier Member

    Joined:
    Mar 10, 2015
    Messages:
    140
    Likes Received:
    6
    Ya, it is a workaround..... The problem is that Shell command turns the display of slower
     
  7. santinabella

    santinabella New Member

    Joined:
    Jan 19, 2018
    Messages:
    2
    Likes Received:
    0
    Thanks @joaomgcd, I added the System Lock action and will test it later today when I leave my home. I have one question: I'm using Google mesh wifi with 3 access points all with the same SSID. In my Tasker Wifi Connected State, when I tap the search button to select a wifi SSID, there are 6 instances of my SSID (3 in the 2.4 ghz band and 3 in the 5 ghz band). Do you recommend selecting all six or only the three in the 5 ghz band since that's what my phone primarily connects to?
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    6,545
    Likes Received:
    580
    If they all have the same SSID you can just set it once :)
     
  9. yo-less

    yo-less New Member

    Joined:
    Feb 20, 2018
    Messages:
    2
    Likes Received:
    0
    Hey joaomgcd, first of all thanks for the AutoTools development. I made the switch from Android Marshmallow to Oreo (8.1) last night and can't seem to disable the lock screen with AutoTools any more. Tasker activates the profile but nothing happens, the lock screen stays enabled. When I run all the tasks manually, I can see that it's supposed to be working as AutoTools Secure Settings / Automatic Lock is preceded by a green dot, however the Lock Screen stays in place. Has the lock screen mechanism changed for Oreo 8.1?
     
  10. yo-less

    yo-less New Member

    Joined:
    Feb 20, 2018
    Messages:
    2
    Likes Received:
    0
    I have an update on this, I have found a workaround and can provide a more detailed problem analysis.

    The culprit seems to be the system's lock screen settings. If I go to Settings > Security & Location > Screen Lock and select the Settings Wheel, there is an option entitled "Automatically lock" which was set to "Immediately". I would expect AutoTools to override this setting with its "Secure Settings / Automatic Lock" feature, but it doesn't. So if I set the "Automatically lock" to say "30 minutes" (which is the longest duration that I can choose) Tasker and AutoTools are able to enable and disable the lock screen. It seems that AutoTools doesn't go deep enough into the systems with its changes so the default Android setting overrules anything AutoTools sets.

    There is a workaround I could use to make it work as expected. The app "Gravity Screen" has a "Special Settings" section with the feature "Disable Lock Screen" which seems to be able to override the Android setting. So if this is enabled, AutoTools works as I was used to under Marshmallow.

    Is it possible that I have overlooked a step in setting up AutoTools? Or do you need to change its code to make it work under Android Oreo right away?
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    6,545
    Likes Received:
    580
    Yeah, that setting needs to be kept to a high time, or else AutoTools can't do it's thing :) Unfortunately I haven't found a way to change that setting with AutoTools sorry!

    BTW, that's step number 1 in the tutorial, right?
     
  12. SantiagoM

    SantiagoM New Member

    Joined:
    Jun 12, 2018
    Messages:
    3
    Likes Received:
    0
    Hi

    I’ve been having issues with this Project, wich is very usefull because Android’s Smart Lock is not reliable.
    The problem I’ve been having is that not always the exit task works. I mean that sometimes, when I’m out of home, I turn on the phone and it is unlocked.
    I want to share with you my fix (and the first task made by myself).

    The trigger is when screen is on (state). That means that every time I turn on the screen (no matter if it’s locked or not), it triggers the task.

    And the task is: (It’s in spanish)

    A1: Wait[ MS:0 Segundos:1 Minutos:0 Horas:0 Días:0 ]
    A2: AutoTools Secure Settings [ Configuración:Automatic Lock: 0 Cuenta atrás (segundos):60 ] Si (if) [ %WIFI ~ off | %WIFII !~R PipeNet ]
    A3: Vibrar [ Tiempo:50 ] Si (if) [ %WIFI ~ off | %WIFII !~R PipeNet ]

    The variable WIFI is for WIFI state and WIFII is for WIFI info (SSID).

    So, when the screen gest on, tasker Will check if WIFI is off or if WIFISSID does not match with My WIFI SSID (PipeNet), then it will set Secure Setting – Automatic Lock to 0.
    And, also, for confirmation only, with the same conditional, the phone will vibrate for 50ms.

    I hope it helps the comunity, and sorry for my poor english.
     
    Last edited: Jun 12, 2018
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    6,545
    Likes Received:
    580
    Thank you very much! :)
     
  14. SantiagoM

    SantiagoM New Member

    Joined:
    Jun 12, 2018
    Messages:
    3
    Likes Received:
    0
    Joao
    Is there any way to take "Automatic Lock" of "AutoTools Secure Settings" as a variable?
    I want to use it as a variable for a conditional.
    Thank you very much!
     
  15. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    6,545
    Likes Received:
    580
    Use the "Custom Setting" section to read the setting with
    • Type: Secure
    • Name: lock_screen_lock_after_timeout
    • Input Type: String
    • Enable Read Setting
    Hope this helps! :)
     
  16. SantiagoM

    SantiagoM New Member

    Joined:
    Jun 12, 2018
    Messages:
    3
    Likes Received:
    0
    Solved it. Works like a charm.

    Thank you again!!
     
    Last edited: Jun 15, 2018
  17. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    6,545
    Likes Received:
    580
  18. ted

    ted New Member

    Joined:
    May 27, 2015
    Messages:
    1
    Likes Received:
    0
    I was successfully using auto tools to disable and enable the lock screen on my Nexus 5X. I moved everything over to my new Moto G6, including the back up of my Tasker profile and tasks. All the profiles and tasks are there now. I disabled the lock screen with power button and ran ABD commands from my computer but it's not working. The profile recognizes my wifi. When I manually run the two tasks, I get a green light but no lock screen. Any suggestions?
     
  19. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    6,545
    Likes Received:
    580
    Can you please export your profile's description (not xml) so I can take a look? Long-click the profile in Tasker->export description Thanks in advance
     

Share This Page