Solved Perform task failing

Discussion in 'AutoWear' started by Fettkeewl, Sep 8, 2017.

  1. Fettkeewl

    Fettkeewl New Member

    Joined:
    Sep 5, 2017
    Messages:
    9
    Likes Received:
    0
    Hi again,
    I have created a task in Tasker which gets my current location from Google maps api and posts the street im on. I call it GetLocation.
    Inside this function I use flash text and create a notification sent to my watch, both containing the same variables so showing the same info on phone and watch.
    When I run this task manually from within itself it works without issue.
    My current location gets flashed and sent to watch.

    Now to the problem, I have created another task called TaskLauncher which makes a list on my watch that is to be used as a task launcher for other tasks such as the afore mentioned, GetLocation.
    When I tap the corresponding task on my watch I use %awmessage in conjunction with perform task to select which task is to be run. When I do a perform task on my GetLocation function it works as it should up to the point when it's supposed to display the results.
    My phone flashes with the Adress I'm on but the notification sent to my watch is for some reason empty.

    So in conclusion, running GetLocation manually, works fine. Through perform task, I get no info sent to my watch. Any clues as to why this behavior is happening?
     
  2. Fettkeewl

    Fettkeewl New Member

    Joined:
    Sep 5, 2017
    Messages:
    9
    Likes Received:
    0
    It seems that autowear had stopped working outside of Tasker..
    1. I created a list menu
    2. With 3 items, 1-3
    3. When I launch my task from Tasker works, it flashes %awmessage
    4. When I launch my task from autowear on my smartwatch by using &APPOPENED& event Tasker does not recognize anything
    Notice that I shake my watch prior to pressing a list item. Autowear talks to watch but not to tasker
    I made short screen recording here
    http://s000.tinyupload.com/download.php?file_id=82208782443077591579&t=8220878244307759157969851
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    4,913
    Likes Received:
    440
    Can you please check AutoWear logs and see if you're seeing the commands there? thanks
     
  4. Fettkeewl

    Fettkeewl New Member

    Joined:
    Sep 5, 2017
    Messages:
    9
    Likes Received:
    0
    Yes the commands are sent but Tasker isn't picking them up
     

    Attached Files:

  5. Fettkeewl

    Fettkeewl New Member

    Joined:
    Sep 5, 2017
    Messages:
    9
    Likes Received:
    0
    I cleared my log so it wouldnt be so massive, did a simple test.
    • Turn on watch
    • Hit "AutoWear"
    • My list screen is launched
    • Press an item
    • Receive no flash toast on phone
    version 1.0.26

    OS Build MMB29M.N910FXXS1DQH8
    OS Code 23
    Device SM-N910F
    Manufacturer samsung
    Product trltexx

    States - 2017-09-11 16:01:13.350 - New com.joaomgcd.autowear.util.WearState: &SHAKE&;
    Commands - 2017-09-11 16:01:13.314 - New Last Command: &SHAKE&;
    Commands - 2017-09-11 16:01:06.474 - New Last Command: 1;
    States - 2017-09-11 16:01:05.297 - New com.joaomgcd.autowear.util.WearState: &APPOPENED&;
    Commands - 2017-09-11 16:01:05.240 - New Last Command: &APPOPENED&;
    States - 2017-09-11 16:01:01.494 - New com.joaomgcd.autowear.util.WearState: &SHAKE&;
    Commands - 2017-09-11 16:01:01.482 - New Last Command: &SHAKE&;
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    4,913
    Likes Received:
    440
    And you're absolutely sure that Tasker is enabled and you have an enabled profile with the AutoWear condition with the &APPOPENED& command filter?
     
  7. Fettkeewl

    Fettkeewl New Member

    Joined:
    Sep 5, 2017
    Messages:
    9
    Likes Received:
    0
    Tasker is enabled, all my other profiles work as they should automatically.
    The list screen works if go into Tasker and press the play button as seen in the video
    Im not using any profiles for this specific task, is that the issue?
    I've just created a task which I want to run when I open autowear from my watch
     

    Attached Files:

  8. Fettkeewl

    Fettkeewl New Member

    Joined:
    Sep 5, 2017
    Messages:
    9
    Likes Received:
    0
    Alright this might be all me it seems.. testing with a profile that reacts to events. Was not aware that this was the requirement for it to be picked up

    Yupp.. my bad sorry for wasting your time...! It works when I have a specific profile to pick up on these events, boy do I feel stupid.. thanks alot!
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    4,913
    Likes Received:
    440
    Glad to see you figured it out! :)
     

Share This Page