AutoInput Answer Call, Press Number - UI Query Issues, AutoInput Error

Discussion in 'AutoApps' started by Bombay317, Mar 27, 2020.

  1. Bombay317

    Bombay317 New Member

    Mar 27, 2020
    Likes Received:
    Hi friends, I have been trying to do the classic
    • Detect phone call from specific number
    • Answer it
    • Switch to Phone "dialer" app
    • press the keypad
    • hit the star key
    The details of the phone:
    • Pixel 3
    • Non-root
    • Android version 10
    My task so far is set up to watch for an incoming phone call from a specific number, and then go into these actions:
    1. Take Call (this works)
    2. AutoInput UI Query (this doens't work)
      1. Configuration App Package: Variables: keypad Only Visible: true
    3. AutoInput Action (this works, but only if I navigate to the app myself)
      1. Configuration Type: Text Value: Keypad Action: Click
    4. Wait
      1. 1 Second
    5. AutoInput Action (works but with an error, it actually clicks '8')
      1. Configuration Type: Text Value: * Action: Long Click
    There are two parts that dont work, #2 and #5. I have actually tried #2 a few different ways. I have tried "AutoInput UI Query" following this suggestion. It doesn't work for me, it basically just hangs at this point. I have tried also AutoLaunch but that also hangs. Any help is appreciated. At this point i think I have something incorrectly configured rather than the actions wrong.

    For #5, I am super confused. I keep trying different inputs, but it keeps clicking different numbers. I want it to click '*', but it keeps clicking anything but. It was clicking '2' for a while, then I tried a few other ways to click, then it started clicking '8'. If I configure it myself, it doenst click in the right place. If I use the auto configure, it also doesnt click the right place. If I pick '*' for text, it wont work. If I pick the x,y coordinates, it also doesnt work.

    Any help on these two?
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Feb 3, 2015
    Likes Received:
    Hi there. Sorry for the delay. Is this still not working for you?

Share This Page