AutoNotification Accessibility setting is getting disabled in Marshmallow

Discussion in 'Tasker' started by goon-heaven, May 1, 2016.

  1. goon-heaven

    goon-heaven New Member

    Joined:
    May 1, 2016
    Messages:
    3
    Likes Received:
    0
    Hello.

    I use AutoNotification plugin in Tasker for a simple Toast Intercept to perform other tasks.
    This works very nicely, but after a while, the Accessibility setting is being turned off.
    It also gets turned off when I change AutoNotification configuration in Tasker, but am aware of that and turn it back on.

    Any ideas why the Accessibility setting is being turned off? and how to work around it?
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    Hi. Thanks for your feedback. What device is that on? thanks!
     
  3. goon-heaven

    goon-heaven New Member

    Joined:
    May 1, 2016
    Messages:
    3
    Likes Received:
    0
    Huawei X2 running B209 Kanvip Slim ROM
     
  4. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    Me too. Same problem, same device. How to prevent the system disabling the service?

    My device: 701->703 Kang VIP B209
     
  5. Daniel D

    Daniel D Member

    Joined:
    Feb 11, 2015
    Messages:
    127
    Likes Received:
    11
    Just noticed that I had the same problem on my Sony Z5 Compact (E5823) running firmware version 32.1.A.1.185.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    In theory accessibility services shouldn't be automatically killed. The system shouldn't do that. I'll need to add a persistent notification like I did for AutoVoice's service. Sorry for the trouble.
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
  8. goon-heaven

    goon-heaven New Member

    Joined:
    May 1, 2016
    Messages:
    3
    Likes Received:
    0
    Thank you for this apk.
    I have installed it and confirmed forground option was enabled.
    Unfortunately I have not seen any reduction of disablement of the Accessibility setting.
     
  9. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    It seems all notifications are cleaned up via a service after some minutes. The tasker notification disappears and the new interception toasts also disappears.

    My device: 701->703 Kang VIP B209
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    Unfortunately there's nothing I can do about that. Must be something on your device that's doing that. Sorry!
     
  11. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    Solution found: on Android 6 we have to do a setting on protected apps which is under advanced settings, battery manager.
    Enable 'keep running after screen is off'
    for tasker AND auto notification.
    The option you made for us to test is not necessary. Thank you add sorry for the circumstantials.


    My device: 701->703 Kang VIP B209
     
    goon-heaven likes this.
  12. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    Tasker leads the users to that menu. You should also do, to prevent problems.

    My device: 701->703 Kang VIP B209
     
  13. Daniel D

    Daniel D Member

    Joined:
    Feb 11, 2015
    Messages:
    127
    Likes Received:
    11
    I swear, I cannot find any setting resembling what you are talking about! Could you please be more specific?

    Thanks!
     
  14. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    [​IMG]


    My device: 701->703 Kang VIP B209
     
  15. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    [​IMG]
    The in the middle


    My device: 701->703 Kang VIP B209
     
  16. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    [​IMG]

    My device: 701->703 Kang VIP B209
     
  17. Daniel D

    Daniel D Member

    Joined:
    Feb 11, 2015
    Messages:
    127
    Likes Received:
    11
    That looks like something device/ROM specific...
    Thanks anyway for sharing!
     
  18. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    You should have battery manager. Maybe there is a 3 dot menu or icon for menu.
    Also you have a search menu in settings. This does not contain all keywords, but worth a trial.
    Post your screen which does not contain the option.


    My device: 701->703 Kang VIP B209
     
  19. audioralf

    audioralf New Member

    Joined:
    May 2, 2016
    Messages:
    9
    Likes Received:
    1
    @joaomgcd my solution works until device is booted. Is it normal in 6.0 that these settings have to be manually enabled after reboot?

    My device: 701->703 Kang VIP B209
     
  20. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    It shouldn't... But maybe there's a bug on that specific ROM that does that?
     

Share This Page