AutoTools Error: java.lang.RuntimeException: Timout showing floating view

Discussion in 'AutoApps' started by ponkieponkz, Mar 13, 2018.

  1. ponkieponkz

    ponkieponkz New Member

    Joined:
    Feb 13, 2018
    Messages:
    20
    Likes Received:
    1
    I have floating bar profiles connected to variable states. But I'm having issues I cannot resolve.
    My profiles/tasks are executed.
    The floating bar (handle) shows.
    at some random point in time the bar handle retracts and the error is shown.

    upload_2018-3-13_12-40-48.png

    This error toast will popup every few minutes and I have no idea where to look to fix it.
    The only way to get the bar back is to launch the task from tasker again. But the error will happen again.
    I've tried to delete the tasks/profiles connected to my floating bars and recreated them, but the same thing happens.

    The logs only show commands... The Tasker Run Log only says 'Err' sometimes...
    I don't know how to fix this.

    Please help me.


    The profile is SO simple!!:
    Code (Text):

    Profile: Floating Bar (Outside) (63)
        State: Variable Value  [ %STATE ~ Outside ]
    Enter: 1. Open Outside Bar (87)
        A1: AutoLaunch Query [ Configuration:App Nickname: OutsideApp Timeout (Seconds):60 ]
        A2: Wait [ MS:0 Seconds:2 Minutes:0 Hours:0 Days:0 ]
        A3: AutoTools Web Screen [ Configuration:Screen Preset: Floating Bar
    Display Mode: Overlay
    Close Overlay ID: floating outside
    Source: /storage/emulated/0/AutoTools/floating_bar/page.html
    Toast Duration: 5000
    Background Color: #00FFEBEE
    Width: 50
    Height: 50
    Gravity: Left
    Offset X: 0
    Animation: Slide In From Left
    Overlay Id: floating outside
    Show Duration: 500
    Hide Duration: 250
    Drag: Draggable Anywhere
    Drag Movements: Vertical Only
    Fling To Dismiss: No Fling To Dismiss
    Update: true
    Icons: %alicons()
    Commands: %alpackages()
    Command Prefix: float
    Visible Items: 2
    Item Padding: 8
    Animation Time: 400
    Custom Expand Icon: android.resource://net.dinglisch.android.tasker/hd_navigation_next_item
    Snap To Pages: true
    Rotate Expander Icon: true
    Floating Bar Color: rgba(0,0,0,0.5)
    Expander Color: #00FFEBEE
    Expander Back Color: #00FFEBEE
    Collapse On Command: true Timeout (Seconds):30 ]

    Exit: 2. Close Outside Bar (88)
        A1: AutoTools Web Screen [ Configuration:Display Mode: Close
    Close Overlay ID: floating outside
    Toast Duration: 5000
    Height: 400
    Gravity: Center
    Animation: Slide In From Top
    Show Duration: 500
    Hide Duration: 250 Timeout (Seconds):30 ]

     
     
    Last edited by a moderator: Mar 14, 2018
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,442
    Likes Received:
    793
    Just to clarify, when that error shows up what happens to the floating bar exactly?
     
  3. PONKiE

    PONKiE New Member

    Joined:
    Feb 5, 2018
    Messages:
    17
    Likes Received:
    0
    The slide to left animation plays and the bar is gone. But there's no exit task in run log. Just the error. I've seen it a couple of times. Most of the times it happens with screen off.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,442
    Likes Received:
    793
    That error happens if for some reason an overlay isn't shown after 10 seconds of trying. So it must be some task that is attempting to show an overlay and is failing for some reason. Do you happen to know which it might be?
     
  5. PONKiE

    PONKiE New Member

    Joined:
    Feb 5, 2018
    Messages:
    17
    Likes Received:
    0
    Maybe it's one of the other bars. I use an outside profile, a work profile and a home profile. All three have a bar attached to it.
    I noticed in the run log that my profile will go from, for ex. Home to Outside.
    The outside task starts right away and launches the work bar.. And the home exit task runs after the outside task started. They both have different id's, but could this be the problem?
     
  6. PONKiE

    PONKiE New Member

    Joined:
    Feb 5, 2018
    Messages:
    17
    Likes Received:
    0
    Also, I now get this everyone I startup tasker. I've jumped back to a backup from yesterday. But this does not help...
     

    Attached Files:

  7. PONKiE

    PONKiE New Member

    Joined:
    Feb 5, 2018
    Messages:
    17
    Likes Received:
    0
    I did not say anything about this error because this happened after trying to set a local image with autotools image muzei. Which does not work for me btw... :(
    But first things first.
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,442
    Likes Received:
    793
    that error usually means that you have uninstalled a plugin that you use in one of your profiles. Can that be it?
     
  9. PONKiE

    PONKiE New Member

    Joined:
    Feb 5, 2018
    Messages:
    17
    Likes Received:
    0
    I think I found a cause for the initial problem, as it's happening again. But I spotted something now. I have one profile that uses your newer loading bars.
    I have it set to a task that switches wallpapers. Most of the times the task executes so fast that the loading bar sorta blinks in and out of view. A few moments later.. My running floating bar will retract and the error is shown.
    I have to fire the bar task again to get it back.

    It seems the loading bar loads (and dissappears) so fast that the plugin still expects it to be shown. 10 secs pass as you said, and the error is shown. This causes my other overlays to dissappear aswell.
    You have any idea for a fix?
     
  10. PONKiE

    PONKiE New Member

    Joined:
    Feb 5, 2018
    Messages:
    17
    Likes Received:
    0


    (*loading bar will flash in the bottom)
     
    Last edited: Mar 17, 2018
  11. PONKiE

    PONKiE New Member

    Joined:
    Feb 5, 2018
    Messages:
    17
    Likes Received:
    0
    My apologies for flooding this thread... Bug hunting is a thing I do... :$

    The exit task of the floating bar was a simple variable clear %LOADING.
    I have fixed this problem for myself by adding a 2 second wait to the exit task of the floating bar profile so the loading bar will always show for a minimum of 2 seconds.

    SOLVED!
    Just so you know what the root cause is. :D
    Have a great weekend!

    (ps: I've hunted down the Tasker startup errors shown in the popup. There were tasks and scenes with missing plugins as you said. Thanks for the tip ;))
     
    Last edited: Mar 17, 2018
  12. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,442
    Likes Received:
    793
    Thank you very much for the update! Now to find out what the issue is! :)
     

Share This Page