AutoLocation Geofences not working on Marshmallow

Discussion in 'AutoApps' started by Jerem01480, Nov 15, 2019.

  1. Jerem01480

    Jerem01480 New Member

    Joined:
    Nov 15, 2019
    Messages:
    4
    Likes Received:
    0
    Hello,

    I am using Autolocation on 3 smartphones to manage tasks on my home automation system.
    On both Android Pie and Oreo, Autolocation is well switching Geofences.
    On the third smartphone, which runs Android Marshmallow, the geofences are not identified.
    Localisation is activated and working well on the phone, if using a place in tasker it works.
    Could you please help ?

    Regards
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    Hi. Did you maybe disable something in Google Play Services on that device? Is it rooted?
     
  3. Jerem01480

    Jerem01480 New Member

    Joined:
    Nov 15, 2019
    Messages:
    4
    Likes Received:
    0
    Hi
    The phone is not rooted, but what do you mean by disabling something in Google Play Services ?
    The phone is the one of my daughter so I manage her usage using Google Family, may be it generates some disturbance ?
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    Thanks. Did you maybe not enable the AutoLocation Geofence Monitor on that particular device?
     
  5. Jerem01480

    Jerem01480 New Member

    Joined:
    Nov 15, 2019
    Messages:
    4
    Likes Received:
    0
    Hi,
    I double checked everything and here are the parameters set:
    • Autolocation privileges in Android : Storage and localisation authorized
    • Autolocation "modules" activated : Geofence Monitor and I also tried to activate Location monitor with option "Force Location monitor to help Geofences"
    When I have a look in the logs I have:
    • For Geofence Monitor, I have the log below and nothing more :
      • Added Geofence Toto
      • Added Geofence Titi
      • Added Geofence Tata
      • Starting Geofence Monitor with this input:
    • For Location Monitor, I have a lot of logs based on the movement of the phone.
     
  6. Jerem01480

    Jerem01480 New Member

    Joined:
    Nov 15, 2019
    Messages:
    4
    Likes Received:
    0
    Hi All,

    A little UP for this topic. I went a little bit further.
    In tasker I set a profile and task to stop and start Autolocation Geofence monitor every 5 minutes.

    This action forces the refresh of the geofences.

    Could we imagine a problem related to battery optimisation or something like that ?
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
  8. MechEng

    MechEng New Member

    Joined:
    Jan 20, 2020
    Messages:
    1
    Likes Received:
    0
    I am having the same issue on Android 10 / Pixel 3XL.

    I think that it is more an issue with the autolocation than with the tasker app.

    When in the autolocation app in the geofenced area and yet the autolocation geofense kept claiming I was outside?? This morning, I was at work (35 miles away) and autolocation claimed I was inside.

    Battery optimizations for both are set to not to optimize.
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    Hi. Are you maybe stopping the AutoLocation Geofence monitor at some point? I actually use it every day and it works really well for me.
     
  10. Keith Nelson

    Keith Nelson New Member

    Joined:
    Jan 17, 2016
    Messages:
    14
    Likes Received:
    0
    I have the same exact issue. When I created the geofence, I set it for 1000 meters as a test, this covers my home area quite well by several homes and my geolocation marker is very much inside. Yet the app shows it is outside.

    What I found interesting is I gave it a name of "Home" and it auto changed it to "Home - Outside" so I am guessing it thinks I am outside of the area. I have a Tasker state which watches for the Inside state, it does not trigger or light up green as it being active. Yet, the task for the Outside state lights up. I have yet to venture out of my home area due to the Pandemic and no need yet to go anywhere. I am working on integrating this so I can use a finite control over my August Smart Lock instead of relying on their app to do the job.

    Android 10 Non Rooted Samsung A20+

    GeoFence and Location Monitor are both active and all of the AutoApps including Tasker are non battery optimized and allowed to run in the background.

    EDIT: Now I have it working, I enabled the "Force Location Monitor to help GeoFences" option Toggled which correctly shows me as "inside" now.
     
    Last edited: Jan 23, 2021

Share This Page