AutoVoice Google Account Issues - Natural Language/Dialogflow Alexa Subscription

Discussion in 'AutoApps' started by Richaardvark, Aug 2, 2019.

  1. Richaardvark

    Richaardvark New Member

    Joined:
    May 27, 2018
    Messages:
    13
    Likes Received:
    0
    Hello!

    I have two Google Accounts setup on my Android device. Each account has its own specific apps purchased in the Play store.

    I had to reinstall AutoVoice and then of course had to re-connect my Google account. I had no issues until I got to the Natural Language/Dialog Flow monthly subscription for Alexa/voice assistants - AutoVoice is wanting me to subscribe via Play Store with the *wrong* Google account. I already have a subscription with my correct Google account and do not want to double-subscribe.

    Here are the exact steps I followed to reconnect my Google account to AutoVoice after reinstalling from the Play Store:
    1. First, I made sure I was logged in to the correct Google account in the Play Store and then reinstalled AutoVoice.
    2. Then, I logged into the correct Google Account in AutoVoice under the "AutoVoice Devices" section.
    3. Next, I setup Natural Language/Dialogflow once again, making sure I used the API key(s) associated with the correct Google account.
    4. I double-checked the Play Store to make sure I was actively logged-in and working with the correct Google account.
    5. I toggle-on the "Use For Google Assistant/Alexa" toggle under Natural Language Intents in AutoVoice, the notification about server costs appears and I acknowledge, then a Play Store purchasing dialog pops up with the wrong Google account information, and asks me to subscribe. There is no way to select the correct Google Account on this dialog. ❌
    • Just to confirm, I check again in the Play Store app and I am operating underneath the correct Google account profile.
    How can I get AutoVoice/Natural Language for assistants to use the correct account like it always has prior? I've reinstalled the app, cleared data, rebooted, etc. without success.

    Please help!
     
  2. Richaardvark

    Richaardvark New Member

    Joined:
    May 27, 2018
    Messages:
    13
    Likes Received:
    0
    Update: I was able to get AutoVoice/the Play Store to recognize my existing subscription associated with the correct Google account by deleting app data for the main Google app, Google Play Services, and Google Account apps. I also reauthorized my account with Amazon under the Alexa Skills setting. I also created a new JSON API key in Dialogflow.

    However :( ... While Alexa does recognize and respond with my proper Natural Language commands, nothing happens on my Android device - no "toasts" appear after giving AutoVoice commands to Alexa. This happened before, all the time, and the only way I could fix it was by clearing all the data in the AutoVoice app and re-configuring everything once again (sigh). But I'm hesitant to do this again because I don't want AutoVoice to go with the wrong Google account again after I finally got it to recognize the correct one...
     
  3. Richaardvark

    Richaardvark New Member

    Joined:
    May 27, 2018
    Messages:
    13
    Likes Received:
    0
    I took a chance and cleared the AutoVoice app data and reset-up everything again - it's working!


    Now I just hope it stays working/I'm going to avoid touching anything in the settings...
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Glad it's working for you!
     

Share This Page