AutoVoice Natural Language unavailable after some time

Discussion in 'AutoApps' started by lechuck, Jul 18, 2018.

  1. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    That means that the commands are not even reaching your phone... Do they start working again if you go to AutoVoice -> Devices?
     
  2. lechuck

    lechuck New Member

    Joined:
    May 31, 2017
    Messages:
    28
    Likes Received:
    0
    i enabled the toast for natural language on my device and will check if it will be triggered next time when it seems not to work.
     
  3. lechuck

    lechuck New Member

    Joined:
    May 31, 2017
    Messages:
    28
    Likes Received:
    0
    ok, as mentioned before i enabled the toast but it didnt work. couldnt see a toast when it stopped listening.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    And going into AutoVoice -> Devices didn't bring them back?
     
  5. lechuck

    lechuck New Member

    Joined:
    May 31, 2017
    Messages:
    28
    Likes Received:
    0
    unfortunately not

    Edit: after not working another time I tried it again and this time it said “user not authenticated" but then this message disappeared and all devices showed up in that menu. After that it worked again
     
    Last edited: Nov 15, 2018
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    And did it stop working since?
     
  7. lechuck

    lechuck New Member

    Joined:
    May 31, 2017
    Messages:
    28
    Likes Received:
    0
    It worked after that but have to wait until it stops working to verify this. So far no issues but that's just because I didn't use it. I use it more often in the evening :)
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
  9. lechuck

    lechuck New Member

    Joined:
    May 31, 2017
    Messages:
    28
    Likes Received:
    0
    Ok, this time going into the devices menu didn't work either. Had to go through all options until it triggered a toast again. So we are back to zero
     
  10. Malversan

    Malversan New Member

    Joined:
    Nov 2, 2018
    Messages:
    8
    Likes Received:
    0
    I confirm that going into AutoVoice -> Devices does not solve the issue.

    What do you mean with ”the commands are not even reaching your phone”? They are not reaching AutoVoice, other Assistant features work.
     
  11. lechuck

    lechuck New Member

    Joined:
    May 31, 2017
    Messages:
    28
    Likes Received:
    0
    well that's the thing, right now noone knows why this is happening. Internet and other services work (including Tasker).

    @Malversan do you have a list of Apps installed on your device, could be worth to compare our app list. who knows maybe it is something we both have installed and is blocking autovoice at some point
     
    Last edited: Nov 19, 2018
  12. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    By "reaching your phone" I mean that commands from AutoVoice have to be sent from Google Assistant to my server and then sent back to your phone. It's a long round-trip but that's the way it has to be done unfortunately...
     
  13. lechuck

    lechuck New Member

    Joined:
    May 31, 2017
    Messages:
    28
    Likes Received:
    0
    i wiped my device and installed android 4.4 (had 7.1.2 before on my nexus 7). the device is old, so 4.4 should fit better and so far it is running smooth and autovoice kept working. will report back after a couple of test weeks.
     
  14. Malversan

    Malversan New Member

    Joined:
    Nov 2, 2018
    Messages:
    8
    Likes Received:
    0
    I found that activating ”Autovoice Google Now Integration” in the system accessibility menu makes the issue appear less often.

    I'm using Google Assistant under Android Oreo and not Google Now, however
     

Share This Page