AutoRemote New AutoRemote Code and EG

Discussion in 'AutoApps' started by bmello777, Nov 11, 2019.

  1. bmello777

    bmello777 Member

    Joined:
    Oct 19, 2016
    Messages:
    39
    Likes Received:
    0
    Hi, I've been using AutoRemote for years. I noticed that my computer off switch wasn't working through EventGhost anymore, so I decided to investigate months later.

    Turns out I had to renew the AutoRemote address and reconfigure in EventGhost. So, I did that. Went into apps and cleared all the data to generate a new address. the autoremote.joaoapps code.

    So, I head on over to EG and try to register it and I cannot.

    I uninstalled and reinstalled and, upon opening, AR gernerated a goo/gl code. Once again, I cleared storage and relaunched. AR generated a new autoremote.joaoapps.com code, but the new one doesn't work in EG.

    Please Help!
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,472
    Likes Received:
    796
    Hi. What happens when you try to add it to EG? Can you please check here: https://joaoapps.com/autoremote/eventghost/
    Particularly this part:
     
  3. bmello777

    bmello777 Member

    Joined:
    Oct 19, 2016
    Messages:
    39
    Likes Received:
    0
    Sorry for the LATE reply.
    Yes, in EventGhost AutoRemote Plugin Item Settings I entered the:
    Device Name: "SHIELDtv"
    Device Key: ..the part after "?key=" from my working AutoRemote URL.

    I then add it to my device list. Once I hit "Apply" a new tab opens in my Chrome browser on my PC that lets me choose which acct to login to. From there, I get this message:

    Sign in with Google temporarily disabled for this app

    Any ideas?

    Edit: I see that Google has disabled things AGAIN on this thread: https://forum.joaoapps.com/index.php?threads/autoremote-plugin-to-eventghost-home-assistant.55917/
    This seems to also be an issue when trying to register Join with EventGhost as well.
     
    Last edited: May 9, 2020
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,472
    Likes Received:
    796
    Thanks, yeah, Google has disabled Google Drive access unfortunately. If you close that window and then just use the pushes, do those work normally?
     
  5. bmello777

    bmello777 Member

    Joined:
    Oct 19, 2016
    Messages:
    39
    Likes Received:
    0
    I cannot push anything through EventGhost.

    As a workaround, I was able to save the AutoRemote command as a shortcut on my desktop that opens in a new window to send the desired push/message to my Nvidia Shield. I also had to use DisplayFusion to close that window whenever it opens. I'm sure there is another way to do this, but I hope that Google enables access again.

    My smart home setup cannot rely on just Google Assistant and IFTTT, lol.
     
  6. bmello777

    bmello777 Member

    Joined:
    Oct 19, 2016
    Messages:
    39
    Likes Received:
    0
    I'm also using juanmtech's video mentioned in the post (previously linked a couple of posts up) to use Google Assistant/IFTTT/Join to trigger turning on computer and PS4. The IFTTT applet runs but I get nothing sent to join using the process he talks about in the tutorial. Everything else works as far as join goes. (clipboard, note to self, etc). Is this Google Sign in issue affecting the webhooks IFTTT feature as well?
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,472
    Likes Received:
    796
    It shouldn't, no :( This only affects signing in to AutoRemote to access Google Drive.
     

Share This Page