Solved Signal notifications not sent

Discussion in 'Join' started by Arek, Jan 28, 2018.

  1. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    Hi,

    I can't get Join to send Signal notifications anymore. I switched from Join Beta a few days ago to the regular version because of the "not logged in" error and can't get it to work anymore. all other notifications are working fine, just not signal - which would be the most impportant ones.

    I've already tried to reinstall the appp, the chrome app, deleting google drive files etc. but nothing worked. Any idea? Someone else using Signal?

    Thanks!
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,588
    Likes Received:
    731
    Hi there. Did it work correctly while you were on the Join beta?
     
  3. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    Yes, never had any problems with Signal, even before I switched to the beta version, that's why I'm at a loss...
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,588
    Likes Received:
    731
    Is Signal maybe not selected as an app to sync notifications?
     
  5. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    it is selected. even tried to deselect, reselect, deselect devices to sync to and reselect them again, nothing helped :(
    btw: SMS (i use signal also as my sms app) notifications get synced, but not the native Signal messages.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,588
    Likes Received:
    731
    Can you please try enabling the option to send all in group? Does that make them send?
     
  7. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    no, unfortunately not :(
    but i noticed something strange: when I have a signal message notification which doesn't get sent and then (while the notification is still active) I'll receive an SMS (which triggers a signal notification, which gets sent), the previously not sent signal message notification also got sent - this somehow is the only time (since the new installation of join), when a signal message notification got sent o_O
     
  8. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
  9. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    Quck update: I upgraded to Oreo and reinstalled Join, but still the same situation – everything is working except (native) Signal notifications. Very strange...
     
  10. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    Is really no one else using Join and Signal??
    Since I've tested on different roms, different Android versions and all other app-notifications are working finde (as stated even signal-notifications for sms) this can't be a rom-related problem or something else...
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,588
    Likes Received:
    731
    Sorry for the delay. Can you verify that the signal app is selected in the Notification Apps setting? Thanks!
     
  12. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    yes, it's selected – was the first thing to check ;)
     
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,588
    Likes Received:
    731
    Sorry, there are so many people to respond to that I sometimes lose track :) Do you receive all other notifications normally?
     
  14. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    no problem ;)
    yes, all other notifications work without any problmes
     
  15. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,588
    Likes Received:
    731
    Just to confirm, this is the app, right?
     
  16. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    yes, correct!
     
  17. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,588
    Likes Received:
    731
  18. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    Thanks, gonna try and report back.
    Should I roll back to the normal version afterwards?
     
  19. Arek

    Arek New Member

    Joined:
    Jan 28, 2018
    Messages:
    16
    Likes Received:
    0
    OK, here you go:
    org.thoughtcrime.securesms: 0|org.thoughtcrime.securesms|1338|null|10215: Not sending because isGroupSummary
    org.thoughtcrime.securesms: 0|org.thoughtcrime.securesms|1338|null|10215: lines length: 0
    org.thoughtcrime.securesms: 0|org.thoughtcrime.securesms|1338|null|10215: Final text: [message goes here]

    Seems the "Summary" Group is the problem but I don't see any way to assign a group or define which one should dbe send and which not?
     
  20. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,588
    Likes Received:
    731
    Can you try toggling the "Send All In Group" option in the Android app's notification settings? :)
     

Share This Page