AutoWear Text Screen, ignore prefix on 'command on show'

Discussion in 'AutoApps' started by Waffel, Jun 10, 2018.

  1. Waffel

    Waffel New Member

    Jun 7, 2018
    Likes Received:
    just noticed that a Text Screen won't send a prefix for 'command on show' - is this intended? On all other commands like: command on hide, tap, log tap, the prefix works just fine.

    How to reproduce: go to Tasker Profiles add an event profile with Event->Plugin->AutoWear under Configuration, let everything on default. Link this Profile to an anonymous task with the action: Flash->Text: %awmessage
    Go to AutoWear app: add an new Screen -> Text Screen, enable 'Trigger for Events', set 'Command Prefix' to myprefix, goto Advanced and set 'command on show' to showing.
    Now after the Text Screen appears on your watch, you will see a toast notification on your phone which shows only 'showing', should be 'myprefix=:=showing'. Is this intended?

    Also noticed, that if I set for 'command on show': open or opened, this will lead to an infinite loop, were the Text Screen will start an close forever.

Share This Page