AutoLocation Geofence won't trigger while device is locked.

Discussion in 'AutoApps' started by TensE, Dec 2, 2016.

  1. TensE

    TensE New Member

    Joined:
    Jun 29, 2015
    Messages:
    13
    Likes Received:
    0
    I have been struggling with this issue for a while where Tasker isn't scanning for changes at all while device is locked. I have setup a geofence to force my phone to be awake and scan for WiFi to trigger my Home task when connected to my home wifi.
    The profile triggers fine when I drive and use the GPS app as it picks up the location updates from the app, but when I walk with the phone in my pocket it doesn't trigger the geofence nor connect to WiFi while screen is off. Only when I turn the screen back on it scans and updates. Is there a way around this? I have a Galaxy S7 Edge - rooted - stock TW
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    Hi. Make sure that you're not blocking Google Play Services in any way on your device for it to work correctly. thanks
     
  3. TensE

    TensE New Member

    Joined:
    Jun 29, 2015
    Messages:
    13
    Likes Received:
    0
    Play services are not blocked. Should i disable Doze on Play Services too? I have done that for tasker and all the autoapps that I have, but so far haven't noticed a difference.
     
: geofence, scannig

Share This Page