AutoTools Toggling mobile data

Discussion in 'AutoApps' started by Motocykal, Oct 25, 2016.

  1. Motocykal

    Motocykal New Member

    Joined:
    Oct 25, 2016
    Messages:
    2
    Likes Received:
    0
    Hi all,
    Has anyone tried to use AutoTools to toggle mobile data (as well as flight mode) successfully?

    I've already performed the adb shell grant permission via my PC. (I didn't get any confirmation that the command executed properly though. The prompt just appeared, indicated that the adb command was completed.)

    I've created a test task with only one action - Plugin -> AutoTools -> Secure Settings -> Configuration -> Mobile Data -> Disable

    I've run the task using the "play" button at the bottom of the task edit window and the following "error message" appears below the task action:

    16.51.44/E FIRE PLUGIN: AutoTools Secure Settings / com.twofortyfouram.locale.intent.action.Fire_Setting: 5 bundle kets
    16.51.44/E AutoTools Secure Settings: plugin comp:com.joaomgcd/autotools/com.joaomgcd.autotools.broadcastreceiver.BroadcastReceiverFire
    16.51.44/E add wait type Plugin1 time 60
    16.51.44/E add wait type Plugin1 done

    I'm using a stock Sony Z3 Compact running Marshmallow 6.0.1
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    Sorry, but that doesn't actually tell me what the error is. Can you please enable the "Continue Task on Error" option in the action that's giving you the error and on the next step use a flash action with the text %errmsg?
    Thanks in advance
     
  3. Motocykal

    Motocykal New Member

    Joined:
    Oct 25, 2016
    Messages:
    2
    Likes Received:
    0
    Hi Joao,

    Apologies. In my excitement, I forgot to run the auto tools app in the phone and activate the trial. :p

    Anyway, I've done that and the disable mobile data action appears to be running without any errors. I've done and you suggested and the flash action just displays "%errmsg".

    Does this mean my phone is unfortunately one of the few it doesn't work on? I've noticed that the action toggles the quick settings, but mobile data is still active.

    Is there anything else you would like me to do to help you debug the issue?
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
  5. snej81

    snej81 New Member

    Joined:
    Apr 24, 2016
    Messages:
    13
    Likes Received:
    0
    Mobile data works on my S7 edge.
     
  6. kmilkman

    kmilkman New Member

    Joined:
    Oct 29, 2016
    Messages:
    1
    Likes Received:
    0
    I have a note 5 that it works on. The problem I'm having is that the mobile data does not function once it has turned back on. I confirmed the settings are actually changing. However, the toolbar indicator remains grayed-out when it toggles on, and I don't have any internet connection. Any help is appreciated.
     
  7. Claudio GUimaraes

    Claudio GUimaraes New Member

    Joined:
    Jan 6, 2018
    Messages:
    9
    Likes Received:
    0
    I have the same issue
     

Share This Page