Accessibility services getting disabled everytime

Discussion in 'Tasker' started by roooii, May 11, 2016.

  1. roooii

    roooii New Member

    Joined:
    May 11, 2016
    Messages:
    14
    Likes Received:
    1
    Hello,

    I just bought some of your apps such as AutoInput, AutoRemote and Tasker itself. On my phone these apps work great, but on my Android TV Box (Tronsmart S95 Telos Android 5.1.1 Stock Rom) it keeps disabling the accessibility services each time I try to do something.

    For example when I try to record with AutoInput it moves the app to the background and tries to open up a notification to start recording. But that notification is only visibile for 1 seconds and then it disappears. When I go back to AutoInput it shows me that the accessibility service is no longer enabled. This sucks because I cannot record anything with AutoInput this way.

    This happens also with other apps that require accessibility services.

    I have tried many apps such as a memory locker to prevent my app from closing. But unfortunately that didn't work. It still closes the app/notification.

    Help is very much appreciated as I am out of options to try.

    Greetings,
    Roy
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,973
    Likes Received:
    759
    Hi there.

    The recording feature shouldn't need the accessibility service to be running.
    But in any case, did you try enabling the "Foreground" option inside AutoInput?
     
  3. roooii

    roooii New Member

    Joined:
    May 11, 2016
    Messages:
    14
    Likes Received:
    1
    Thanks for your help Joaomgcd. Apparently there is something in the stock rom of Tronsmart that causes the accessibility to stop. They told me they would have to tweak the rom so that these apps are allowed... Kinda sucks that I have to wait for a new version of the rom now. Or do you happen to know how I can tweak the rom myself? :p
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,973
    Likes Received:
    759
    That I have no idea how to do :D Sorry!
     
  5. JR Jones

    JR Jones New Member

    Joined:
    Jun 29, 2016
    Messages:
    4
    Likes Received:
    1
    Sorry for bringing up a really old thread. I had this problem too. I think it's more of an Android bug when you have more than one accessibility service enabled at a time, I've had this happen on my N6 and N6p. Are you rooted? I've been using Secure Settings for a while to enable all of my accessibility services on boot. You could give that a try.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,973
    Likes Received:
    759
    JR Jones likes this.
  7. JR Jones

    JR Jones New Member

    Joined:
    Jun 29, 2016
    Messages:
    4
    Likes Received:
    1
    I just started using AutoTools for it yesterday. I love how you can have just one task to set them all instead of a different one for every service like Secure Settings requires. Outstanding work
     
    Adlx likes this.
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,973
    Likes Received:
    759
    Thank you very much! :)
     
    JR Jones likes this.
  9. zhedielj

    zhedielj New Member

    Joined:
    Apr 3, 2019
    Messages:
    1
    Likes Received:
    0
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,973
    Likes Received:
    759

Share This Page