AutoRemote AR and EG Calling url error

Discussion in 'AutoApps' started by scotts, May 30, 2020.

  1. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    140
    Likes Received:
    1
    Although AR and EG work together, I cannot get them to communicate directly with my device's local IP.

    I've set my device in the AR EG plugin with the IP 192.168.1.157 (static IP on my network), and enabled the option to try connecting locally. When I execute the EG macro, I get the following (from the EG log)...

    Calling url http://192.168.1.157:1817/
    803: Couldn't make request via local network: <urlopen error [Errno 10061] No connection could be made because the target machine actively refused it>
    Calling url https://autoremotejoaomgcd.appspot.com/sendrequest
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,472
    Likes Received:
    796
    Did you enable the Autoremote Wifi Service on the device with the corresponding Tasker action?
     
  3. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    140
    Likes Received:
    1
    Are you referring to selecting wifi for a device under Registered Devices? Then yes, wifi for the PC is enabled. Otherwise, not certain where this service is located.


    Sent from my Note8
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,472
    Likes Received:
    796
    Nope, sorry, I meant in Tasker, add an AutoRemote Wifi action and turn on the service. Only then can the device receive messages from the network.
     
  5. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    140
    Likes Received:
    1
    That was it, thank you. I was unaware of requiring such a service...is it a drain on the battery?
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,472
    Likes Received:
    796
    In my experience it is not :)
     
  7. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    140
    Likes Received:
    1
    Although I have the above referenced AR wifi Action enabled, this still occurs when the phone has been idle. Its like the Perm Notification Action is not always active. Any thoughts?

    Error received:
    803: Couldn't make request via local network: <urlopen error [Errno 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond>
     
: eventghost

Share This Page