AutoTools Audio Safe Volume State not working

Discussion in 'AutoApps' started by Gio Stefani, Apr 5, 2018.

  1. Gio Stefani

    Gio Stefani New Member

    Joined:
    Apr 5, 2018
    Messages:
    3
    Likes Received:
    1
    So I've enabled permissions to autotools by issuing ".\adb shell pm grant com.joaomgcd.autotools android.permission.WRITE_SECURE_SETTINGS". I check the current state by issuing by issuing ".\adb shell settings get global audio_safe_volume_state" and it returns a value of 3. I user Tasker in conjunction with autotools to set audio_safe_volume_state to an int value of 2. I step though the process and it completes. When I go back to the adb shell command, the value is still at 3. I've rooted other phones before, but really don't want to root my Samsung Galaxy S8+. I have followed this article to the letter and even downloaded the XML files and imported them into Tasker (https://www.xda-developers.com/how-to-automatically-disable-the-high-volume-warning-without-root/). I've added one other task to the list to increase the Media Volume to maximize it. When I reboot the phone, it all reverts back and I get the nag screen about the volume level. There is no reason why this shouldn't be working.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,055
    Likes Received:
    768
    Just to clarify, does it not work at all for you? Or does it just not work after a reboot? Thanks
     
  3. Gio Stefani

    Gio Stefani New Member

    Joined:
    Apr 5, 2018
    Messages:
    3
    Likes Received:
    1
    Only after reboot. Thanks
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,055
    Likes Received:
    768
    It must be the system that's resetting something. In that case use an AutoTools Secure Settings action at every reboot and that should fix it right? :)
     
  5. Gio Stefani

    Gio Stefani New Member

    Joined:
    Apr 5, 2018
    Messages:
    3
    Likes Received:
    1
    I’m already using AutoTools Secure Settings as a task under Tasker.

    Setting Type: Global
    Name: auto_safe_volume_state
    Input Type: int
    Value: 2
     
    Alex Kezar likes this.
  6. Stephen Irving

    Stephen Irving New Member

    Joined:
    Nov 7, 2016
    Messages:
    6
    Likes Received:
    0
    Did you ever find a solution to this as I have noticed it has stopped setting on my Galaxy S9+ on Pie (no root)
     
  7. Alex Kezar

    Alex Kezar New Member

    Joined:
    Apr 30, 2019
    Messages:
    1
    Likes Received:
    0
    Help. Anything?
     
  8. Robert B

    Robert B New Member

    Joined:
    Jul 11, 2018
    Messages:
    25
    Likes Received:
    1
    Use Autoinput to click okay on the popup. It's the only way it will work since the upgrade to Pie on Samsung. Setting the safe_volume_level does not work anymore
     
: autotools

Share This Page