AutoCast AutoCast problems and questions

Discussion in 'AutoApps' started by Rich Wallace, May 1, 2015.

  1. Rich Wallace

    Rich Wallace Member

    Joined:
    Apr 10, 2015
    Messages:
    42
    Likes Received:
    1
    OK, so I've been playing with AutoCast for a while now, and either I'm doing g something wrong or it isn't functioning as expected.

    AutoCast Query
    This seems to take forever to run, and only seems to run successfully once.
    Eg I'm casting some video or photo and query it for the file name. First time it runs nice and quick and gives the correct result in %acfile. Anytime after and it won't complete. But I get no error message or code, even with 'Continue task after error' checked.

    Casting local media.
    This seems temperamental at times
    Sometimes it works, others it doesn't. And it is often slow, although I suspect this is down to my poor WiFi network?

    My first project was media streaming, with AutoNotification integration. Idea being select media from gallery app, use AutoShare to cast, with a notification (with pause, skip and stop buttons) updated each time media changes with the file name. I've pasted the profile description below.
    Profile: AS Command - Cast Videos (223)
    Event: AutoShare [ Configuration:Command: Cast Video
    Sender: all
    Subject: all
    Text: all
    Image: all ]
    Enter: Anon (236)
    A1: Variable Set [ Name:%videos To:%asfile() Do Maths:Off Append:Off ]
    A2: AutoCast [ Configuration:
    Starting Casting Screen
    Persistent Notification: true
    Cast Device: Richards Chromecast
    Screen: Full Screen Media
    Screen Notification Title: Casting....
    Screen Notification Time Out: 10
    Video: %videos
    Video AutoPlay: true
    Package:com.joaomgcd.autocast Name:AutoCast Timeout (Seconds):3000 ]
    A3: Profile Status [ Name:AN Event - Casting Media Pause Set:On ]
    A4: Profile Status [ Name:AN Event - Casting Media Next Set:On ]
    A5: Profile Status [ Name:AN Event - Casting Media Stop Set:On ]
    <QUERY NOTIFICATION>
    A6: AutoCast Query [ Configuration:Is AutoCast Casting: true
    Get Chromecast Status: true Package:com.joaomgcd.autocast Name:AutoCast Query Timeout (Seconds):50 ]
    A7: If [ %aciscastingautocast !Set ]
    A8: Flash [ Text:No Long:Off ]
    <LOOP PROTECTION>
    A9: If [ %qtime > 10 ]
    A10: Stop [ With Error:Off Task: ]
    A11: Else
    A12: Goto [ Type:Action Label Number:1 Label:QUERY NOTIFICATION ]
    A13: End If
    A14: Else If [ %aciscastingautocast = 1 ]
    A15: AutoNotification [ Configuration:Title: Casting
    Text: %acfile
    Status Bar Icon: ic_notification_media_route
    Id: casting media
    Button 1: cast pause media
    Label 1: Pause
    Icon 1: av_pause_over_video
    Button 2: cast next media
    Label 2: Next
    Icon 2: av_next
    Button 3: cast stop media
    Label 3: Stop
    Icon 3: ic_action_cancel Package:com.joaomgcd.autonotification Name:AutoNotification Timeout (Seconds):0 ]
    A16: End If
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    803
    Thanks for the report. I'll try and figure out what's wrong with the AutoCast Query action. Sorry for the trouble.
    Slow media streaming is very probably due to a slow wifi connection, yes.
     
  3. Rich Wallace

    Rich Wallace Member

    Joined:
    Apr 10, 2015
    Messages:
    42
    Likes Received:
    1
    Thanks João,
    Another problem surfaced today.
    Quite often, when using the AutoShare profile above, it will run fine, once only.
    Then any time following, the tasker run log shows a rejCopy error, which I think is saying there is a copy of the task running.
     
  4. Rich Wallace

    Rich Wallace Member

    Joined:
    Apr 10, 2015
    Messages:
    42
    Likes Received:
    1
    Sorry to be a total pain....
    The AutoCast query doesn't fill the %acfile variable of the media being cast is a photo?
     

Share This Page