AutoCast Autocast youtube playlist doesn't play next

Discussion in 'AutoApps' started by enderman, Feb 23, 2017.

  1. enderman

    enderman New Member

    Joined:
    Feb 23, 2017
    Messages:
    5
    Likes Received:
    0
    Not sure how to get this working.

    I'm trying to cast youtube playlist using autocast and tasker. I tried several urls. something like this:
    https://www .youtube .com/watch?v=uEJuoEs1UxY&list=RDuEJuoEs1UxY

    (added spaces to avoid being embedded on this page)

    I tried youtu.be share link as well.

    but it only plays the first song and stops. youtube only worked with best guess. not any web page.

    my ultimate purpose is to use alexa pi to search youtube and play a mix playlist. so far stuck in this.

    Thanks
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    806
  3. enderman

    enderman New Member

    Joined:
    Feb 23, 2017
    Messages:
    5
    Likes Received:
    0
    Thank you for the reply. I just tested it with pre-made and it worked. is there a way to get it to work with those on the fly somehow? on mobile chrome browser, those playlists work. but maybe not possible through sdk.

    A workaround idea I have. How about the ability to feed autocast with a video url using another custom url we enter in the config page (e.g. example.com/getmyvideos. autocast would then get the first video(s) to play by sending a GET request to the given page. after it finishes playback of those videos it goes back to the same page to get new ones. and so on. that way we can simulate on the fly playlists.

    Thanks a lot
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    806
    @enderman thanks for the suggestion! Yes, that's a possible solution! Thanks. I'll try to figure out a workaround-
     

Share This Page