AutoInput AutoInput not recognizing buttons

Discussion in 'AutoApps' started by k1282, Nov 21, 2016.

  1. k1282

    k1282 New Member

    Nov 21, 2016
    Likes Received:
    I am new to tasker and am currently evaluating my options with regard to the following use case: In the morning I...
    1. ... wake up to my android android alarm
    2. ... run the remote app of my amplifier, toggle it on, switch it to the appropriate input
    3. ... run the music player app controlling the music player on my Intel NUC and press play (soetimes I browse playlists, choose and press play afterwards)
    I tried Autoinput but the amplifier app is crappily designed: I can use AutoInput to run the app, turn on the amplifier, but I cannot tell autoinput which Input to select, this is because the moment I click on "On" in the amplifier app, the status changes from "Off" to "on"; I then need to click on "On" in order to select the desired input from a dialog window. The problem is: I cannot tell AutoInput to use the new screen with the dialog window, because swiping down for the notification bar will make the dialog window within the app disappear.
    I also tried using Autoinput for the music player app (Roon), but Autoinput does not recognize any buttons or menus within the app. I tried gesture in AutoInput, as there is a side menu when swiping from left to right for selecting a playlist, I also tried Action mode, but the only available event, which made sense, were the coordinates, but even the coordinates did not return anything.
    Any advice?
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Feb 3, 2015
    Likes Received:
    About the amplifier app, you should just be able to make AutoInput click "on" or "off" depending on what you want without using the "Easy Setup" option by simply editing the AutoInput Action fields. Have you tried that? :)

Share This Page