AutoRemote Autoremote : not responding when screen is off

Discussion in 'AutoApps' started by Theoorl45, Aug 24, 2016.

  1. Theoorl45

    Theoorl45 New Member

    Joined:
    Aug 24, 2016
    Messages:
    3
    Likes Received:
    0
    I use Autoremote with Tasker within my android tablet.
    But, when screen is off, nothing happens. When screen is on, all is okay.

    I don't think it's the right way... others topics in this forum doesn't have answers...

    Can you help me to find what's wrong ?

    NB : sorry for my broken english, I'm french.

    Regards,
    --
    Sylvain
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Hi, thanks for contacting me. What device are you using? Is it rooted? What Android version is it using? Thanks!
     
  3. Theoorl45

    Theoorl45 New Member

    Joined:
    Aug 24, 2016
    Messages:
    3
    Likes Received:
    0
    I use an android 4.4.2 tablet (samsung galaxy tab 3 7'').
    No, it's not rooted : I failed to root it....
     
  4. MikeW

    MikeW Member

    Joined:
    Feb 16, 2015
    Messages:
    113
    Likes Received:
    9
    I'm having similar problems with BT messaging. I posted my problem over in the G+ community.
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Can you please check if the messages are received in the AutoRemote logs? Maybe it's just Tasker that isn't waking up to react to the messages?

    Thanks in advance
     
  6. MikeW

    MikeW Member

    Joined:
    Feb 16, 2015
    Messages:
    113
    Likes Received:
    9
    Thanks for asking. I was just about to post here that my issue appears to be solved. I don't quite know what I did, but it started working yesterday. (Haven't checked yet today to see if it's still working.). I had been testing by sending messages directly through the AR interfaces, so it wasn't Tasker.
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Great to know :)
     
  8. MikeW

    MikeW Member

    Joined:
    Feb 16, 2015
    Messages:
    113
    Likes Received:
    9
    I spoke too soon. This morning it's problematic again. The logs are showing "Couldn't send through Bluetooth: read failed, socket might closed or timeout, read ret:-1"
     
  9. Theoorl45

    Theoorl45 New Member

    Joined:
    Aug 24, 2016
    Messages:
    3
    Likes Received:
    0
    Heu, why my topic is solved ???? It's not solved at all !

    I would like to tell you what there is in the logs but...where can I find the autoremote logs ?
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Sorry, I marked it as solved before when you said it was working.

    To get the logs please go into AutoRemote -> click on the little sheet icon at the bottom.

    Thanks
     
  11. MikeW

    MikeW Member

    Joined:
    Feb 16, 2015
    Messages:
    113
    Likes Received:
    9
    I think it was me that said my issue was solved. Sorry about that. didn't mean to hijack the thread; I just thought my issue was similar enough to add in here. For what it's worth, my issue isn't really solved either; I still have very inconsistent result.

    If I have more information/questions I'll start a new thread.
     
  12. Daveo

    Daveo New Member

    Joined:
    Sep 9, 2016
    Messages:
    3
    Likes Received:
    0
    I also I also seem to have this issue. Logs show "error sending text... Error doing request: org.apache.http.conn.connecttimeoutexception: connect to/xxx.xxx.xxx.xxx:1818 timed out." If I recall correctly this might have started after an OTA android update. When this happens, I turn the screen on and it starts working, after a while, I'm unable to send messages until I turn the screen back on. It is almost like some sort of sleep function prevents messages being sent even though wifi is set to remain on during sleep and as far as I can see it does so. In addition when I initiate a task through tasker I set a beep to know it is being run,it seems tasker is being called as expected but autoremote is unable to communicate with eventghost.

    Im running android 6.0.1
     
  13. Claudio GUimaraes

    Claudio GUimaraes New Member

    Joined:
    Jan 6, 2018
    Messages:
    9
    Likes Received:
    0
    Estou passando pelo mesmo problema.

    Quando a tela do celular está desligada por algum tempo, parece que o celular não consegue enviar mensagens. Eu passo o mesmo problema com o Unified Remote. Eu tenho que ligar a tela do celular para que o evento seja enviado para o computador. O que eu gostaria é que eu pudesse dar o comando para o Google Home e o celular, mesmo estando em stand by reconhecesse e enviasse o comando para o PC.
     
  14. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Será que o problema é do Unified Remote?
     

Share This Page