AutoRemote Autoremote/Tasker only working when app has focus.

Discussion in 'AutoApps' started by Homeautomation, Jun 25, 2015.

  1. Homeautomation

    Homeautomation New Member

    Joined:
    Jun 25, 2015
    Messages:
    12
    Likes Received:
    0
    Hi, I have a strange problem that starts after some updates few weeks ago.

    I have a working concept with tasker that listen on autoremote commands.
    Everything works perfect if I open Autoremote and have that app open but when I minimize it only works maybe 5 secs after Autoremote lost focus. I have even factoryreset the tablet and start over from beginnig but still the same.

    If I open autoremote and view incomming message, all of them are there. Don't know if they load when I open the app.
    Any ideas? Running Android 4.2.2
    Device never goes to sleep, screen always on.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Do you have an app on your phone that kills other apps? Something like greenify? :) From your description it really sounds like that's the case.
     
  3. Homeautomation

    Homeautomation New Member

    Joined:
    Jun 25, 2015
    Messages:
    12
    Likes Received:
    0
    Hi, no not on this device. The device is factory restored, installed tasker, autoremote, Acapela TTS.
    This tablet is only connected with wifi. I did a test so I know that tasker is running, I create a recurring event every 2 minutes with a beep and popup and it always trigger.
    I have used this for the last year everyday without any issue, I have a simular problem on my other device Sony Xperia Z2.
    Works most of the time but can miss several commands from autoremote, if I open autoremote logs all commands are there. Even if I use a short TTL = 10secs. Wait a minute and open autoremote logs and it have also receive that short ttl message so I guess the "receiver" of the message never go to sleep. Have to be something between tasker and autoremote.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Never saw that issue before. Do you find that it happens while the screen is off? Or doesn't that seem to matter? Also what version of the apps are you using?
     
  5. Bort76

    Bort76 New Member

    Joined:
    Jun 26, 2015
    Messages:
    2
    Likes Received:
    0
    I've been having the same problem, just as described above. Only after a recent update (within a month or so), I'll see the received message in AutoRemote, but no corresponding Tasker action. Happens only rarely and unpredictably. Tasker is running in the foreground and Tasker's log shows no activity at all associated with the corresponding profile.

    No hibernation apps used. Running Android 5.0.
     
  6. Homeautomation

    Homeautomation New Member

    Joined:
    Jun 25, 2015
    Messages:
    12
    Likes Received:
    0
    Hi, the tablet is set to never sleep/turn off screen when power is connected. Using the latest app from google play.
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
  8. Bort76

    Bort76 New Member

    Joined:
    Jun 26, 2015
    Messages:
    2
    Likes Received:
    0
    This looks just like my problem. Except, my events are not exactly "rapid". I have a device "check in" once an hour. Maybe 5-20% of the check-ins, depending on the day, don't trigger the Tasker action but do show up in the Autoremote logs. Looking forward to the Tasker update that fixes this.
     
: autoremote

Share This Page