AutoTools AutoTools 2.0 + webscreens, how to get started?

Discussion in 'AutoApps' started by Wouter, Jul 28, 2017.

  1. nmcj

    nmcj Member

    Joined:
    Mar 24, 2016
    Messages:
    90
    Likes Received:
    2
    So I just know I am doing something dumb. I want to make a simple web screen showing one image. When a tasker variable changes, I want the web screen to update to show a different image. But damn if i can make it work. I don't even think that the methods I've been messing with are wrong - I've tried Case/Switch and a few other things. Rather, I just don't know how to format the html correctly.
    This should work, but I can't get it to do anthing:
    Code (Text):
    <!DOCTYPE html>
    <html>
    <head>
            <script src="autotoolsfunctions.js"></script>
            <link rel="stylesheet" type="text/css" href="autotoolsstyle.css">
            <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
        <meta name="autotoolswebscreen" type="variablejs" id="image" label="Image" description="Image to display "  defaultValue="1, 2, 3" />
    </head>

        <body>

        </body>
        <script type="text/javascript">

                            var imageSource = null;
                            switch (image) {
                                    case 1:
                                            imageSource = "files/flipped1.jpg";
                                            break;
                                    case 2:
                                            imageSource = "files/iflipped2.jpg";
                                            break;
                                    case 3:
                                            imageSource = "files/flipped3.jpg";
                                            break;
                            };
                            <img src=imageSource>

     
        </script>
    </html>
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    The problem is that the file paths need to be full file paths and not relative paths like that. Sorry, unfortunately it's a limitation of Web Screens! Can you get it to work like that?
     
  3. Wouter

    Wouter Member

    Joined:
    Feb 4, 2016
    Messages:
    71
    Likes Received:
    2
    Thank you Joao, the recent update of the navigation drawer webscreen fixed this problem. It's working great now!
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
  5. nmcj

    nmcj Member

    Joined:
    Mar 24, 2016
    Messages:
    90
    Likes Received:
    2
    Cool. Thanks I'll try that
     
  6. rmackinnon

    rmackinnon New Member

    Joined:
    Jan 22, 2018
    Messages:
    1
    Likes Received:
    0
    Hi y'all (wouter, if you're from ATX, we know each other!),

    I'd like to get the AutoWeb beta, but not sure how. I found it listed with the other beta apps. It says I need to join the G+ community, and I did. It also says I need to download and install a web browser app--I have one; it's Chrome. But when I click the AutoWeb icon, it just hangs on an unpopulated Google Play screen. What else do I need to do? Thanks!

     
: spotify

Share This Page