AutoVoice AutoVoice action error 404 when setting context

Discussion in 'AutoApps' started by pronobis, Jun 22, 2019.

  1. pronobis

    pronobis New Member

    Joined:
    Jun 22, 2019
    Messages:
    7
    Likes Received:
    0
    I recently migrated my tasker and autovoice setup from one phone to another. Unfortunately, during that process one thing stopped working. I have an intent that is followed by another intent. They share context. After the first action is detected by a tasker profile, the task uses the AutoVoice Natural Language Context action to set the context parameters for the following intent. This used to work brilliant. However, since I migrated to my new phone, the action results in AutoVoice action error java.io.IOException: Error 404.

    Any ideas what could be wrong?
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
  3. pronobis

    pronobis New Member

    Joined:
    Jun 22, 2019
    Messages:
    7
    Likes Received:
    0
    Thanks! That fixed the original error. However, now it's impossible to set input/output contexts for natural language command. Again, error 404.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
    Hi. Sorry, I don't understand. Is that not the part that was not working in the first place?
     
  5. pronobis

    pronobis New Member

    Joined:
    Jun 22, 2019
    Messages:
    7
    Likes Received:
    0
    No, initially, the problem was with setting the context values using the tasker action. Now, instead, the problem is with defining contexts in using AutoVoice->Natural Language->Commands->Command->Input Contexts/Output Contexts.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
  7. pronobis

    pronobis New Member

    Joined:
    Jun 22, 2019
    Messages:
    7
    Likes Received:
    0
    Thanks, no error when setting context, but setting the command in AutoVoice->Natural Language results in Error:null
     
  8. pronobis

    pronobis New Member

    Joined:
    Jun 22, 2019
    Messages:
    7
    Likes Received:
    0
    Besides, the Tasker action AutoVoice Natural Language Context, despite not throwing an error, does not seem to work. The context isn't set.
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
    Hi. How did you check that the context is not set? Can you clarify?
     
  10. pronobis

    pronobis New Member

    Joined:
    Jun 22, 2019
    Messages:
    7
    Likes Received:
    0
    Well, I'm trying to run a tasker profile that worked before the upgrade. So, I'm assuming that what I'm doing is correct.

    My setup is the following. I have two intents one following the other. The first intent creates the output context X and the second intent accepts the input context X and the response it generates includes values of variables in the context. Some of those variables are set by the first intent, but some I would like to set in Tasker in response to the first intent. So, I tried the following:
    1) Using a single context X and setting its variables using the Tasker AutoVoice action in response to the first intent. This makes it possible to activate the second intent which depends on context X (the context is set not only by the AutoVoice action but also the first intent). Still, the variables available to the second intent are only those set by the first intent, and not the AutoVoice tasker action.
    2) Using two contexts X and Y, where X is created by the first intent, and Y is set by the tasker action. This will prevent the second intent from being activated at all (now it depends on two contexts). It seems that the tasker action does not set the second context.
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
    Thanks. Just to clarify, when you set the new JSON string to use V2 of the dialogflow API, did you keep the original tokens for V1?
     
  12. pronobis

    pronobis New Member

    Joined:
    Jun 22, 2019
    Messages:
    7
    Likes Received:
    0
    Yes, I have both v1 and v2 tokens.
     
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
    Ok, can you please try with the latest version from Google Play and then disable and re-enable the option in AutoVoice > Natural Language > Commands > Use For Google Assistant/Alexa?
     
: autovoice, tasker

Share This Page