AutoVoice AutoVoice and "hide dialog" setting

Discussion in 'AutoApps' started by Oddboy, Jan 28, 2020.

  1. Oddboy

    Oddboy New Member

    Joined:
    May 10, 2017
    Messages:
    6
    Likes Received:
    0
    Hi all,

    I know this question has been asked before, but none of the threads i found have a definitive answer, so i thought I'd raise the topic again.

    I am unable to get AutoVoice to recognize voice commands when the "hide dialog" setting is turned on. I'd love to be able to use it, but it just doesn't work. My Profiles activate and tasks run successfully when the setting is turned off. When it's turned on, I get nothing. I use a Flash action to show me what AV heard and it just returns "%avcomm", or "%avmessage", %avcommnofilter, or whichever variable I try.

    Here's an example profile:
    Code (Text):
     
        Profile: AutoVoice: Show Something (293)
            Restore: no
            Event: AutoVoice Recognized [ Configuration:Command: "(show)|(let me see) (regex)" ]
        Enter: AV: Show Something Task (299)
            <Show something>
            A1: Anchor
            A2: If [ %avcommnofilter ~ all ]
            A3: Flash [ Text:No way! Long:Off ]
            A4: Else If [ %avcommnofilter ~ *schedule ]
            A5: Flash [ Text:%avcommnofilter ]
            A6: End If
       
    Again, this profile and task work great if the hide dialog setting is turned off, but doesn't work when hide dialog is turned on. When it's on, the A5 action just returns %avcommnofilter.

    I have tried giving AV the "draw over other apps" permission as mentioned in another thread, but it did nothing.

    I'd love to find a way to make this work without the Google dialog.

    Thanks for your time!

    Joel
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,967
    Likes Received:
    758
    Weird. Seem like on your phone the service responsible for voice recognition is not working? Did you root your device or otherwise disable anything related to google apps on it?
     
  3. Oddboy

    Oddboy New Member

    Joined:
    May 10, 2017
    Messages:
    6
    Likes Received:
    0
    Nothing special that i know of. Samsung s9+ with official OS.

    Are there relevant setting i can verify?

    Like i said, it works fine when hide dialog setting is not activated. It only fails when it is checked.

    Is there a way to reset voice settings?
     
  4. Oddboy

    Oddboy New Member

    Joined:
    May 10, 2017
    Messages:
    6
    Likes Received:
    0
    just picked up Tasker 5.9.2.beta3 and using AutoVoice 3.6.2. behaviour with "hide dialog" has slightly changed. when "hide dialog" is checked, I can now hear the Google Assistant "beep" in the background, but immediately after, the "beep" that I get when the assistant thinks there's "no network connectivity". if I were trying to explain this to one of my little girls, the sound is sort of like "ding, clunk" "ding, clunk". I have tried enabling "offline mode" as well, but that seems to have no effect.

    so it's slightly better with beta3, but I still can't get AV to capture the voice commands when "hide dialog" is checked.
     
  5. Oddboy

    Oddboy New Member

    Joined:
    May 10, 2017
    Messages:
    6
    Likes Received:
    0
    Alright, I got it. I offer my humble apologies.
    I use the Hotword plugin to have my own hot word listening, and despite turning on the setting for Hotword plugin to let go of the mic when another app wants it, it wasn't letting go fast enough. I added a step to disable it, and a brief wait to the beginning of the task and it all works now, even with dialog hidden.

    Thanks for your patience @joaomgcd!
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,967
    Likes Received:
    758
    Glad you got it! :)
     

Share This Page