AutoVoice Autovoice not passing natural language commands to tasker

Discussion in 'AutoApps' started by Matust, Sep 16, 2017.

  1. Matust

    Matust New Member

    Joined:
    Mar 20, 2017
    Messages:
    18
    Likes Received:
    1
    Hi,

    I have been trying to get autovoice natural language commands working but I can't get autovoice to pass the commands to tasker. I can get the correct response in testing area of autovoice. When I use the command (ask autovoice to navigate home) in google assistant I get the toast 'recieved possible commands: navigate home' but this doesn't seem to get passed to tasker and give me the natural language response (would you like to avoid tolls). In natural language I have use for google assistant/Alexa selected. In personal assistant > commands I have made sure it's empty.

    Do you have any ideas?
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Hi there. Thank for the report. Does your natural language command have an action associated to it? Can you check please? Thanks!
    Also, is the option to allow natural language commands in AutoVoice -> Natural Language -> commands -> Bottom enabled?
     
  3. Matust

    Matust New Member

    Joined:
    Mar 20, 2017
    Messages:
    18
    Likes Received:
    1
    Yes, for trouble shooting I have the action set to flash a toast and set a notification. I also have the button button use for google asssistant/Alexa selected but it doesn't seem to be working
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Can you please show me a screenshot of your natural language commands screen? Thanks in advance!
     
  5. Matust

    Matust New Member

    Joined:
    Mar 20, 2017
    Messages:
    18
    Likes Received:
    1
    Sure thing
     

    Attached Files:

  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Please click the navigation command there, then pull up on the options list and select Action and set an action for it. Any unique action name will do.
    Do the same for the switches command.
    That should make it work :) Hope this helps
     
  7. Matust

    Matust New Member

    Joined:
    Mar 20, 2017
    Messages:
    18
    Likes Received:
    1
    oh wow that worked! Thanks alot!
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    No problem, glad I could help! :)
    Out of curiosity, how did you create those commands exactly? AutoVoice automatically fills in an action for you when you create commands there. Thanks again!
     
  9. Matust

    Matust New Member

    Joined:
    Mar 20, 2017
    Messages:
    18
    Likes Received:
    1
    I used the api.ai website
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799

Share This Page