AutoVoice AutoVoice Offline

Discussion in 'AutoApps' started by stevexyz, Jan 9, 2020.

  1. stevexyz

    stevexyz New Member

    Joined:
    Dec 8, 2015
    Messages:
    6
    Likes Received:
    0
    Using the "offline" option in an AutoVoice Recognize action in Tasker does not seem to work. I know this is mentioned in the FAQ, but it links to a dead post on Google+.
    Is there any info available about this? Offline recognition would be very useful since I have a task using voice recognition that usually runs in a parking garage where I have very poor reception.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,055
    Likes Received:
    768
    What happens when you try to enable that option?
     
  3. stevexyz

    stevexyz New Member

    Joined:
    Dec 8, 2015
    Messages:
    6
    Likes Received:
    0
    After enabling the "offline" option, recognition fails consistently (every time). Nothing is recognized; no error code is set in %err. The Google dialog box always says "Didn't catch that. Try speaking again." Toggling "Hide Dialog" or "Language Model" does not help. After unselecting "Offline Mode" everything seems to work normally again, as long as there is internet connection!
     
  4. stevexyz

    stevexyz New Member

    Joined:
    Dec 8, 2015
    Messages:
    6
    Likes Received:
    0
    I can grab some logcat output of a failed recognition if that would be helpful.
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,055
    Likes Received:
    768
    Hhmm I think some languages don't work offline. What language are you trying to use with it?
     
  6. stevexyz

    stevexyz New Member

    Joined:
    Dec 8, 2015
    Messages:
    6
    Likes Received:
    0
    I'm using en-US. If I select "Language" in the AutoVoice Recognize config dialog, the choice that comes up is a dialog with "System Default - null" as the only choice. The "null" seems suspicious. If I use "Language Code" to enter a manual override of "en-US" this does not make any difference. In my Android system settings "Languages" the only language I have set up is "English (United States)".
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,055
    Likes Received:
    768
    Weird, cause it works for me :/ What if you use the option to not show a popup?
     

Share This Page