AutoVoice Autovoice Profiles not triggering on specific device

Discussion in 'AutoApps' started by Hugo, May 27, 2020.

  1. Hugo

    Hugo New Member

    Joined:
    Jun 10, 2019
    Messages:
    4
    Likes Received:
    0
    Hi,

    I have been using Tasker and Autoapps for a couple of years and I couldn't be without these apps so thank you! This is the first time posting, I have been using the forums and Google a lot in the past to solve my other issues but this time I really need assistans.

    Since the start I have been using two phones with Tasker and Autovoice. One phone is at home always unlocked and connected to my other devices (TV, PC etc.).
    I use three different ways of sending commands to the phone at home:
    Starting tasks on my main phone which sends "Test Command" to the phone at home.
    Ask Autovoice to send command to the phone at home
    Routines in Google Assistant which sends commands to my phone at home

    I am now using Autowear as well and I sucessfully send voice commands from the watch to my main phone with a hardware button on the watch, however, all my real tasks are on my phone at home, not connected to my watch, so I had to setup new Profiles and Tasks with Natural Language actions triggering new Autowear Commands.

    Now as I have started having real Tasks on my main phone, my issue is that I was never able to start Tasks on my main phone using Google Assistant. I receive the voice command toast on both phones but the profile is triggered only on the phone at home. I can send test commands and I can use the Natural Language shortcut and it works fine, but using Google Assistant the Tasks are not triggered, only on the phone at home.

    Can you think of a way to keep my real Tasks on my phone at home and trigger them with voice and watch? Otherwise I need to set up all Profiles and Tasks on my main phone and my phone at home, as well as solving the Google Asisstant + Autovoice issue described in this post.

    Thanks in advance!

    • you haven’t saved your Tasker configuration. Back out from Tasker with the back key to do this
      Done
    • Tasker is disabled
      Tasker is enabled
    • The AutoVoice profile is disabled
      AutoVoice profile is enabled
    • Your command filter does not match what you said
      The command is matching
    • The task is executing, but you don’t realize it for some reason
      Paying close attention
    • If you’re using AutoVoice with the Google Assistant or Amazon Echo your device might not be configured to receive these commands. Open AutoVoice > Devices to register your device and try again.
      Both phones are available under Devices. If i tap either phone and send a voice command, the profiles are triggered (But not using Google Assistant)
    Main phone: OnePlus 6T
    Phone at home: Motorola Moto X Play
     

    Attached Files:

  2. Hugo

    Hugo New Member

    Joined:
    Jun 10, 2019
    Messages:
    4
    Likes Received:
    0
    Should I solve this by forwarding any comands (by smartwatch and voice) from main phone to phone with home?
    Is below a good solution?

    Main phone:
    Autovoice Natural Language Profile which trigger Task to send Test Command to phone at home.

    Phone at home:
    Set up one Profile with Autovoice Natural Language which sends Action
    Set up all my Tasks
    Set up one Profile per Task which triggers by Action
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,480
    Likes Received:
    801
    Yes, that should work, although it shouldn't be necessary :)

    Did you maybe sign-in with a different account in Google Assistant? Maybe try signing out and signing in again from AutoVoice there and make sure you're using the same account you used in the AutoVoice app?
     
  4. Hugo

    Hugo New Member

    Joined:
    Jun 10, 2019
    Messages:
    4
    Likes Received:
    0
    Hi, thanks for getting back to me.

    I have set up all profiles on my phone at home and set up forwarding of Natural Language and Autowear commands from main phone to phone at home.

    After some fiddling profiles are not triggering on neither phone now when command is received from Google. I read that the Google link to Autovoice is currently down? I am using English language and I use the Google assistant on my phone and Google mini. I have signed out and in again and I'm on the same Google account.
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,480
    Likes Received:
    801
    The link is not down anymore, so it should work normally. Does it help if you delete the phone that's not being recognized from the device list and then try re-adding it?
     
  6. Hugo

    Hugo New Member

    Joined:
    Jun 10, 2019
    Messages:
    4
    Likes Received:
    0
    Hi,

    That solved the issue!
    I was not aware you had to hold on the device to being up the delete option. Perhaps there could be a prompt if the devices should be deleted or re-added when re-connecting the profile?

    Thanks!
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,480
    Likes Received:
    801
    That actually shouldn't be needed, but I'm glad it worked for you! :) Thanks!
     

Share This Page