AutoVoice Autovoice virtual device in Alexa not working

Discussion in 'AutoApps' started by Calinutz, Feb 13, 2019.

  1. Calinutz

    Calinutz New Member

    Joined:
    Feb 13, 2019
    Messages:
    4
    Likes Received:
    0
    I created a virtual device in Autovoice, and Alexa discovered it in the smart home devices list. I also have a profile and task in Tasker that react to this device's change of states.

    Apparently Alexa manages this virtual device ok, as it doesn't yield any error messages (command: Alexa turn on device | Alexa answers: OK), but i guess the device doesn't actually chance states (or maybe it does but Autovoice doesn't intercept it), as i don't get a toast from Autovoice, nor does it trigger the task in Tasker.

    I've tried managing real smart home devices from Alexa (through a Vera controller, and they changed states all-right), so i believe Alexa is doing it's job as it should.

    Autovoice 3.5.4b and 3.5.2
    Alexa app 2.2.257256.0
    Fire HD8 show mode, on fire os 6.3.0.1

    Cal.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    CAn you please try going through the steps here?
     
  3. Calinutz

    Calinutz New Member

    Joined:
    Feb 13, 2019
    Messages:
    4
    Likes Received:
    0
    I've already read the faq before posting here, and i didn't find anything related to the Alexa virtual device. I went again through it, and i still can't find anything.

    Is there anyway to check if the Alexa virtual device changes states ? I can't find anything in the logs.

    BTW. in AutoVoice - Toasts and Logs menu, both "Natural language toast" and "Smart home toast" options have the same description: "If enabled a toast will be shown when a natural language voice command is successfully completed in AutoVoice ".
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Oh, sorry, I just added a part about the echo :)

    • If you're using AutoVoice with the Google Assistant or Amazon Echo your device might not be configured to receive these commands. Open AutoVoice > Devices to register your device and try again.
    Did you do this?
     
  5. Calinutz

    Calinutz New Member

    Joined:
    Feb 13, 2019
    Messages:
    4
    Likes Received:
    0
    it's the bloody Fire HD 8 with FireOS that's something wrong with. AutoVera doesn't receive any state updates either.
    I've tried the exact same setup of AutoVoice and Autovera on a Nexus 7 1st gen Android 4.4.4, and it works a treat !
    i get toasts and everything's tip top.

    So ...any chance you could look into why it isn't working on Fire HD with FireOS ? And maybe find a way :D. It is an Android 7.1.2 (API Level 25) after all.

    i got on the FireHD:
    Google Services framework 7.1.2
    Google Account manager 7.1.2
    Google play services 15.0.90
    Google play store 13.3.17
    Google app. 9.10.7.21

    Is there anything else AutoApps need in order to work ?
     
    Last edited: Feb 14, 2019
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Hmm, maybe Fire HD doesn't have Google Play services and doesn't let you receive GCM pushes?
     
  7. Calinutz

    Calinutz New Member

    Joined:
    Feb 13, 2019
    Messages:
    4
    Likes Received:
    0
    yup you're absolutely right. i have Google Play services installed, but for some reason the device doesn't register for GCM, so GCM is not working, and i just can't wrap my head around why it isn't.

    i guess it would be to much of a hassle for you, and maybe not worth it, to make the autoapps detect the platform they get installed on and use gcm if android, ADM (Amazon Device Messaging) if FireOS ?

    or maybe a microG for AutoApps (like the microG for youtube Vanced) ?
     
    Last edited: Feb 14, 2019
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Sorry, unfortunately I don't even have one of those devices to test on, so I can't be of much help :(
     
  9. Carl Bromiley

    Carl Bromiley New Member

    Joined:
    Apr 26, 2019
    Messages:
    2
    Likes Received:
    0
    Hi there
    First post so sorry if this has been covered already.

    I've got autovoice setup on my phone and have enabled the autovoice smart home skill on my alexa through the site not the app. I've got my phone showing on the autovoice devices in the app and have created an alexa smart home device called phone. My problem is that alexa doesn't discover the device. I've tried refreshing by voice, through the alexa app on my phone and also the website on my pc.

    It seems to work fine with the older autovoice skill on alexa and I get toast notices in the autovoice app on my phone when saying "Alexa, ask autovoice to.. .....", but if I just ask "Alexa, set phone to 50%" I get the response of no device called phone.

    Any help getting the newer skill working would be great as I have some tasker bits and bobs just waiting to be used in my home setup.

    Thanks
    Carl
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Sorry, I'm aware of that issue and I'll try fixing it ASAP. Will get back to you.
     
  11. Maxou

    Maxou New Member

    Joined:
    May 7, 2019
    Messages:
    1
    Likes Received:
    0
    Hello,
    Same problem for me. Unable to add new smart home devices created in autovoice within alexa devices.
    Previous smart home devices still working in alexa.
    Waiting patiently for a fix
    Sincerely
     
  12. Oddboy

    Oddboy New Member

    Joined:
    May 10, 2017
    Messages:
    8
    Likes Received:
    0
    Another one here.

    Samsung s9+
    Android Pie
    AutoVoice (well, I auto everything!)
    Alexa with several echo dots

    I can create smart home devices, but but Alexa isn't discovering them.
     
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Fixed on the server. Should work again! :) Sorry for the delay!
     
  14. Carl Bromiley

    Carl Bromiley New Member

    Joined:
    Apr 26, 2019
    Messages:
    2
    Likes Received:
    0
    Looks like that's done it.

    Many Thanks
     
  15. jmd

    jmd New Member

    Joined:
    Aug 6, 2019
    Messages:
    2
    Likes Received:
    0
    have a Samsung Note 8 same problem here... new to all this but i'm pretty sure i followed everything right and tried many times to relink.
    same problem as a previous user :
    I've got autovoice setup on my phone and have enabled the autovoice smart home skill on my alexa through the site not the app. I've got my phone showing on the autovoice devices in the app and have created an alexa smart home device called phone. My problem is that alexa doesn't discover the device. I've tried refreshing by voice, through the alexa app on my phone and also the website on my pc.
    I'm on the trial version of autovoice...
     
  16. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Hi. Maybe you're signing in with a different account in AutoVoice and Alexa?
     
  17. jmd

    jmd New Member

    Joined:
    Aug 6, 2019
    Messages:
    2
    Likes Received:
    0
    hi. I tried all combos possible as i have two google account. Tried switching many times as i tought that was the problem but doesnt seem to change anything. thanks for the suggestion.
     

Share This Page