AutoWear Autowear Commands not recognized by Tasker

Discussion in 'AutoApps' started by Arasyssss, Jul 15, 2020.

  1. Arasyssss

    Arasyssss New Member

    Joined:
    Jul 15, 2020
    Messages:
    3
    Likes Received:
    0
    Hey guys,

    I am a big fan of AutoWear, but since I have my new phone (Fxtec Pro1) itˋs not working properly.

    >> what I want to do:
    I want so send commands from wear to phone to trigger tasks, using the autowear plugin. Example: When command "L1" received, turn on Light A (see picture). This worked very well with my old phone (LG G6)...

    >> problem:
    I can see, that the command arrives the phone (I can see the small popup, check picture), but nothing happens (I can run the log and even there I see that nothing is triggered, see picture). Now itˋs getting weird: Every 8th - 15th time it works! Means: Tasker receives the command and does what he has to do. After that, again, >8th trys are not successful...

    >> what Iˋve tried already:
    - Phone restart
    - autowear reinstall (on phone and watch)
    - Tasker reinstall
    - Tasker and autowear have every permission they can get without root
    - Tasker and autowear are free from battery optimization by android

    >> what´s my setup:
    - Phone: Fxtec pro1 with Android 9
    - Watch: Fossil gen 5


    Can someone help somehow? That would be awesome!
     

    Attached Files:

  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,421
    Likes Received:
    792
    Hi there. Maybe one of the apps is being blocked from running in the background?
    To make sure Tasker and the AutoApps run in the foreground please check here: https://tasker.joaoapps.com/userguide/en/faqs/faq-problem.html#00

    Pay special attention to the location part. If Tasker doesn't have permission to get location in the background it might not work correctly, so disable and re-enable the location permission and make sure that you allow Tasker to always access it.

    Make sure to check here too: https://dontkillmyapp.com/?app=Tasker

    Hope this helps!
     
  3. Arasyssss

    Arasyssss New Member

    Joined:
    Jul 15, 2020
    Messages:
    3
    Likes Received:
    0
    Hey,

    thanks a lot for your reply! Let´s check, maybe I forgot something?
    • make sure Tasker is enabled - CHECK
    • enable foreground notification in Tasker settings - CHECK, see screenshot 200030
    • enable the "Use reliable alarms" option - CHECK, See Screenshot 200644
    • If you're on Android 10+ allow Tasker to draw over other apps: Open Tasker - Menu - More - Android Settings - Draw Over Other Apps and enable the permission. - CHECK, see Screenshot 201048 and 201111
    • dontkillmyapp.com. This website will show, for your specific vendor, the best way to allow Tasker to work correctly in the background. - CHECK, see Screenshot 201903
    • Disable battery optimization for the apps - CHECK, see Screenshot 202739 and 203009
    • Make sure the Android Settings -> Apps -> Tasker -> Battery -> Background activity option is enabled (this setting may be somewhere else on different OEMs, but it's a very important setting that might be disabled by default on some devices) - CHECK, See above
    • If you want to use features while the screen is off make sure that the options in Preferences -> Monitor -> Display Off Monitoring are enabled for the conditions you want - Not the Problem, because it is Not working while Screen is on
    • Make sure that you disable any "battery saving" apps like Greenify, etc - don't have
    • If you want to have Wifi and Cell based profiles work on Android 8+ make sure that location is enabled on your device and that Tasker has location permissions even when in the background. It's an Android requirement that Tasker can't work around. - cannot find this Option :-/ ... But ist this really necessary? The Problem does even exist when tasker is running in foreground
     

    Attached Files:

    Last edited: Jul 21, 2020
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,421
    Likes Received:
    792
    Thanks for checking! Maybe there's a special extra setting on that phone that you need to further disable to really allow apps to work in the background? Sorry, it's such a nightmare to keep up with all the extra "optimizations" various vendors implement on their systems :(
     
  5. Arasyssss

    Arasyssss New Member

    Joined:
    Jul 15, 2020
    Messages:
    3
    Likes Received:
    0
    I totally understand what you mean... Two steps forward, one step back.

    Thanks a lot for your time. I am a very big fan!

    For me it´s very important to get this issue solved. My whole smart home depends on Tasker / Autowear. So next step, I will write the vendor to help me out :)
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,421
    Likes Received:
    792
    Hope they can help you out!
     
: autowear

Share This Page