AutoWear AutoWear Settings - Disable Bluetooth. can't re-enable

Discussion in 'AutoApps' started by darkamikaze, Mar 11, 2016.

  1. darkamikaze

    darkamikaze New Member

    Joined:
    Mar 2, 2016
    Messages:
    10
    Likes Received:
    1
    Since Android Wear 1.4/6.0.1 rolled up I've been having bluetooth issues with my watch and my car. To alleviate the problem I'm trying to create a profile to temporarily disconnect my AndroidWear device by disabling bluetooth using Tasker/AutoWear Settings. I recall being able to enable it again through Tasker but it seems like now if I disconnect, it's completely disconnected from my phone. Running a task that enables it won't work because it's disconnected X_x. Is there anything that can be done about that?

    Thanks!
     
  2. MikeW

    MikeW Member

    Joined:
    Feb 16, 2015
    Messages:
    113
    Likes Received:
    9
    When my watch s disconnected from the phone it puts up a notification that says "Tap to Re-connect". Maybe you could use AutoNotifcation to "click" that?
     
  3. darkamikaze

    darkamikaze New Member

    Joined:
    Mar 2, 2016
    Messages:
    10
    Likes Received:
    1
    Unfortunately when I do Bluetooth Disconnect through AutoWear it disconnects bluetooth from the watch side. This means even if I click the notification it does nothing since the watch's bluetooth is off.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    That has always been like that unfortunately. the only way to re-enable it is to open AutoWear settings on your watch and enable it there.
     
    darkamikaze likes this.
  5. A.Bhanli

    A.Bhanli New Member

    Joined:
    Apr 12, 2016
    Messages:
    4
    Likes Received:
    0
    Before disconnecting Bluetooth, enable Wi-fi tethering on phone and turn on the Wi-Fi of the watch. After being connected to car bt turn on bt of the watch through Wi-Fi tethering. Problem solved...
     
  6. Idan

    Idan New Member

    Joined:
    Nov 9, 2018
    Messages:
    1
    Likes Received:
    0
    Hi joaomgcd,
    I'm joining darkamikaze's probkem.
    I'm using Tasker and Autowear.
    I need a syntax to feed into "Command to execute", in Autowear, that will be this:
    Wifi is connected

    Once my watch connects to wifi (any, even tethering from phone) bluetooth will turn on.

    Thanks!
     
  7. Heodn2

    Heodn2 New Member

    Joined:
    Jan 23, 2020
    Messages:
    16
    Likes Received:
    0
    I created a task in Tasker to disable Bluetooth at night, but in the morning it won't enable because of the lost Bluetooth connection. Is there anyway I can run these commands locally on the watch?
     
    Last edited: Jun 23, 2020

Share This Page