AutoWeb Autoweb jsonbin

Discussion in 'AutoApps' started by edward.croff2, Jan 5, 2018.

  1. edward.croff2

    edward.croff2 New Member

    Joined:
    May 17, 2017
    Messages:
    6
    Likes Received:
    0
    Hey everybody, I noticed jsonbin.org stopped working so I created an API for jsonbin.io not sure if autoweb API sharing is working or not so I figured I'd post something.

    @joao how should I share sir?

    Sent from my Z982 using Tapatalk
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Hi there, thanks for your contribution! Can you please let me know what stopped working about jsonbin exactly? Thanks!
     
  3. Simon MArinof

    Simon MArinof New Member

    Joined:
    Jan 17, 2018
    Messages:
    1
    Likes Received:
    0
    Hi,
    it's not working from me either:
    this is what I'm doing:

    -installed autoweb
    In autoweb
    -clicked on "your Web services"
    -pressed the plus sign
    -selected import
    -imported Jsonbin.org
    -when asked for a token, I entered my api key provided when I subscribed to the jsonbin.org website
    -the Jsonbin.org says Ready to Use in green (I'm assuming the token is correct at this point)

    Open tasker
    -created a new profile State/wifi connected SSID "added my ssid"
    -create a task
    -create Alert/flash/%DEVMOD
    -create another task
    -create/plugin/AutoWeb/Web service
    -selected Jsonbin.org in API
    -API Action: Set Data For Keys
    -Key: %DEVMOD
    -Value: Home
    -Accept the changes.
    -run the task


    getting this error message:
    15.22.29/E Error: 1867121445
    15.22.29/E { "message": "Invalid auth token provided", "status": 412}

    Any idea what I'm missing or doing wrong?
     
  4. android52

    android52 New Member

    Joined:
    Jul 24, 2019
    Messages:
    4
    Likes Received:
    0
    Hi, I'm wondering if there was an answer to this - I'm stuck at pretty much the exact same thing - trying to do the same thing with sharing variables about location between devices, etc.

    I'm also getting the "Invalid auth token provided" message.
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Hi. I'm still able to use it. Can you try the Get All Values function and see if that works?
     
  6. android52

    android52 New Member

    Joined:
    Jul 24, 2019
    Messages:
    4
    Likes Received:
    0
    Thanks for trying to help, it's appreciated.

    Did you mean the Get All values from the Configuration Screen of the AutoWeb WebService under the Task in Tasker? If so, I still get the same "invalid auth" error.

    I don't have any bins or collections set in Jsonbin.io yet - do I have to create there first?

    Do I have to authenticate first somewhere outside of Auto Web Service action or in a pre-action to working with data?
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    I don't think you need any extra steps. Can you please double check your key to see if it's really the correct one?
     
  8. android52

    android52 New Member

    Joined:
    Jul 24, 2019
    Messages:
    4
    Likes Received:
    0
    Thanks for keeping up with this, and replying.

    I did double check the key (this is the API Key, not the USER ID right), and have tried generating a new key as well (double checked).

    I have also tried copying from the API Key page on JSONBIN.io into an e-mail, sent it to my phone, then copied and pasted the key from the e-mail into the "Secret Key", rebooted the phone and the same error is appearing:

    Error: 1867121445
    {'message': 'Invalid auth token provided', 'status': 412}

    Error 412 in HTML is a precondition failed which would make sense if it doesn't like the key I guess.

    In the API config I have
    Name: Jsonbin.org
    Base URL: https://jsonbin.org/
    Output type: json
    Authentication: SecretKey
    Safegaurd Sensitive Data: Checked
    Secret Key: {Copied from email}
    Secret Key Parameter: token
    Sign-up Website: https://jsonbin.org/_/login

    The secret key and where I created an account was on jsonbin.io not jsonbin.org (which directs to a Github sign in).

    Does that all sound correct?

    Thanks again.
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Hhmm, it should really by at https://jsonbin.org/_/login . If I go there I get access to an API key:

    • username: joaomgcd
    • apikey: ......
    Do you not see that if you login there?
     
  10. android52

    android52 New Member

    Joined:
    Jul 24, 2019
    Messages:
    4
    Likes Received:
    0
    Well, I guess get the APIkey from the right location makes a difference :oops:

    I'm not sure how I got to jsonbin.io - but after creating an account on Github linked to jsonbin.org and using the key provided there, I'm no longer getting the authentication error.

    Thanks for your support!
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Haha :) Great, glad it works now!
     

Share This Page