AutoRemote Bluetooth: Recipient doesn't have a bluetooth connection associated

Discussion in 'AutoApps' started by skribb, Jan 24, 2016.

  1. skribb

    skribb Member

    Joined:
    Mar 5, 2015
    Messages:
    44
    Likes Received:
    1
    "Couldn't send through Bluetooth: Recipient doesn't have a bluetooth connection associated"

    (And then the message is sent via GCM instead.)

    I get this error message even tho both devices have BT enabled and are paired via BT and the recipient device has persistent notification on the bluetooth listener service running. I am clueless as to what could be wrong, is it a bug perhaps?

    The latest entry in my Bluetooth log in AutoRemote says "BEGIN", "service started" etc so it seems to be running?

    thank you
     
    Last edited: Jan 25, 2016
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    That means that AutoRemote doesn't know about the other device's BT properties. Long click the device in your device list and chooose "Set Bluetooth device". Hope this helps!
     
    skribb likes this.
  3. skribb

    skribb Member

    Joined:
    Mar 5, 2015
    Messages:
    44
    Likes Received:
    1
    Hello AutoMaster ;)

    I Long click the device in your device list and chooose "Set Bluetooth device". this didn't work.
    So I also tried refreshing device info and restarting the BT listener. Now it seems to work.

    I will write again if the service poops out. Thanks joao.
     
  4. skribb

    skribb Member

    Joined:
    Mar 5, 2015
    Messages:
    44
    Likes Received:
    1
    Joao, it doesn't work anymore. I have "persistent notification" AND "keep device awake" and it still stops working after 1-2 days. Is there a way to periodically refresh device info or something like that? thanks!
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Maybe you could try stopping and starting the BT service and see if that helps? Sorry for the trouble
     
  6. skribb

    skribb Member

    Joined:
    Mar 5, 2015
    Messages:
    44
    Likes Received:
    1
    Thank you for the quick reply. I restarted the BT service and that seemed to help.. I will implement a periodic reboot of the service in my Tasker profiles, but this shouldn't be a requisite for Autoremote to function. Could it be a bug in Autoremote or is it maybe Tasker-specific?

    I will report back with my findings whether periodically restarting the service actually alleviates my issue.
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Thank you. Can you please check the AutoRemote logs after it stops working and see if there's any clue there? thanks
     
  8. skribb

    skribb Member

    Joined:
    Mar 5, 2015
    Messages:
    44
    Likes Received:
    1
    Here are the logs when it stopped working: http://imgur.com/a/ctz8c/all

    And here it's suddenly working agian: http://imgur.com/a/bV85K/all


    I have a profile now that automatically restarts the service. This has failed to keep it running, however, because I would still get the "service discovery failed" error logged in the Tablet from which I send the BT message.
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Can you please export those as text? There's an export button at the top of the screen. Thanks in advance!
     
  10. skribb

    skribb Member

    Joined:
    Mar 5, 2015
    Messages:
    44
    Likes Received:
    1
    I don't see any export button. I can 'share' the log text but it doesn't capture what's in my screenshots, only the last hour or so of logs. The screenshots are from 5 hours ago.
     
  11. skribb

    skribb Member

    Joined:
    Mar 5, 2015
    Messages:
    44
    Likes Received:
    1
    It happened again, I hope I got the correct logs:

    All - 2016-02-15 11:02:27.372 - Received Message from Lenovotablet: Text: "BackupAlarm=:=08=:=44"
    In - 2016-02-15 11:02:27.341 - Received Message from Lenovotablet: Text: "BackupAlarm=:=08=:=44"
    All - 2016-02-15 11:02:27.296 - Received GCM
    In - 2016-02-15 11:02:27.211 - Received GCM
    All - 2016-02-15 10:26:59.673 - BEGIN mAcceptThreadThread[Thread-1038,5,main]
    All - 2016-02-15 10:26:59.646 - setState() 1 -> 1
    Bluetooth - 2016-02-15 10:26:59.601 - BEGIN mAcceptThreadThread[Thread-1038,5,main]
    Bluetooth - 2016-02-15 10:26:59.595 - setState() 1 -> 1
    All - 2016-02-15 10:26:59.532 - start
    Bluetooth - 2016-02-15 10:26:59.497 - start
    All - 2016-02-15 10:26:59.454 - setState() 3 -> 1
    Bluetooth - 2016-02-15 10:26:59.386 - setState() 3 -> 1
    All - 2016-02-15 10:26:59.342 - Error: disconnected
    bt socket closed, read return: -1
    Bluetooth - 2016-02-15 10:26:59.264 - Error: disconnected
    bt socket closed, read return: -1
    All - 2016-02-15 10:26:57.827 - Received Message from Lenovotablet: Text: "Kaloer_tablet_dismissed"
    All - 2016-02-15 10:26:57.761 - END mAcceptThread
    In - 2016-02-15 10:26:57.721 - Received Message from Lenovotablet: Text: "Kaloer_tablet_dismissed"
    Bluetooth - 2016-02-15 10:26:57.690 - END mAcceptThread
    All - 2016-02-15 10:26:57.580 - setState() 1 -> 3
    All - 2016-02-15 10:26:57.481 - BEGIN mConnectedThread
    Bluetooth - 2016-02-15 10:26:57.418 - BEGIN mConnectedThread
    Bluetooth - 2016-02-15 10:26:57.411 - setState() 1 -> 3
    All - 2016-02-15 10:26:57.310 - create ConnectedThread
    Bluetooth - 2016-02-15 10:26:57.226 - create ConnectedThread
    All - 2016-02-15 10:26:57.168 - cancel Thread[AcceptThread,5,main]
    Bluetooth - 2016-02-15 10:26:57.098 - cancel Thread[AcceptThread,5,main]
    All - 2016-02-15 10:26:57.010 - connected
    Bluetooth - 2016-02-15 10:26:56.963 - connected
    All - 2016-02-15 10:24:04.570 - BEGIN mAcceptThreadThread[Thread-1005,5,main]
    All - 2016-02-15 10:24:04.499 - setState() 1 -> 1
    Bluetooth - 2016-02-15 10:24:04.448 - setState() 1 -> 1
    Bluetooth - 2016-02-15 10:24:04.448 - BEGIN mAcceptThreadThread[Thread-1005,5,main]
    All - 2016-02-15 10:24:04.363 - start
    Bluetooth - 2016-02-15 10:24:04.330 - start
    All - 2016-02-15 10:24:04.282 - setState() 3 -> 1
    Bluetooth - 2016-02-15 10:24:04.240 - setState() 3 -> 1
    All - 2016-02-15 10:24:04.199 - Error: disconnected
    bt socket closed, read return: -1
    Bluetooth - 2016-02-15 10:24:04.132 - Error: disconnected
    bt socket closed, read return: -1
    All - 2016-02-15 10:24:02.334 - Received Message from Lenovotablet: Text: "Kaloer_tablet_started"
    All - 2016-02-15 10:24:02.308 - END mAcceptThread
    In - 2016-02-15 10:24:02.268 - Received Message from Lenovotablet: Text: "Kaloer_tablet_started"
    Bluetooth - 2016-02-15 10:24:02.209 - END mAcceptThread
    All - 2016-02-15 10:24:02.159 - BEGIN mConnectedThread
    All - 2016-02-15 10:24:02.117 - setState() 1 -> 3
    Bluetooth - 2016-02-15 10:24:02.008 - BEGIN mConnectedThread
    Bluetooth - 2016-02-15 10:24:01.964 - setState() 1 -> 3
    All - 2016-02-15 10:24:01.900 - create ConnectedThread
    Bluetooth - 2016-02-15 10:24:01.822 - create ConnectedThread
    All - 2016-02-15 10:24:01.749 - cancel Thread[AcceptThread,5,main]
    Bluetooth - 2016-02-15 10:24:01.690 - cancel Thread[AcceptThread,5,main]
    All - 2016-02-15 10:24:01.591 - connected
    Bluetooth - 2016-02-15 10:24:01.493 - connected
    All - 2016-02-15 10:19:58.320 - BEGIN mAcceptThreadThread[Thread-972,5,main]
    All - 2016-02-15 10:19:58.263 - setState() 1 -> 1
    Bluetooth - 2016-02-15 10:19:58.205 - setState() 1 -> 1
    Bluetooth - 2016-02-15 10:19:58.205 - BEGIN mAcceptThreadThread[Thread-972,5,main]
    All - 2016-02-15 10:19:58.065 - start
    Bluetooth - 2016-02-15 10:19:57.985 - start
    All - 2016-02-15 10:19:57.899 - setState() 3 -> 1
    Bluetooth - 2016-02-15 10:19:57.803 - setState() 3 -> 1
    All - 2016-02-15 10:19:57.758 - Error: disconnected
    bt socket closed, read return: -1
    Bluetooth - 2016-02-15 10:19:57.626 - Error: disconnected
    bt socket closed, read return: -1
    All - 2016-02-15 10:19:56.102 - Received Message from Lenovotablet: Text: "BackupAlarm=:=10=:=44"
    All - 2016-02-15 10:19:56.058 - END mAcceptThread
    In - 2016-02-15 10:19:56.020 - Received Message from Lenovotablet: Text: "BackupAlarm=:=10=:=44"
    Bluetooth - 2016-02-15 10:19:55.931 - END mAcceptThread
    All - 2016-02-15 10:19:55.833 - BEGIN mConnectedThread
    All - 2016-02-15 10:19:55.778 - setState() 1 -> 3
    Bluetooth - 2016-02-15 10:19:55.734 - BEGIN mConnectedThread
    Bluetooth - 2016-02-15 10:19:55.729 - setState() 1 -> 3
    All - 2016-02-15 10:19:55.632 - create ConnectedThread
    Bluetooth - 2016-02-15 10:19:55.578 - create ConnectedThread
    All - 2016-02-15 10:19:55.522 - cancel Thread[AcceptThread,5,main]
    Bluetooth - 2016-02-15 10:19:55.427 - cancel Thread[AcceptThread,5,main]
    All - 2016-02-15 10:19:55.359 - connected
    Bluetooth - 2016-02-15 10:19:55.305 - connected
    All - 2016-02-15 10:19:30.901 - setState() 1 -> 1
    All - 2016-02-15 10:19:30.839 - BEGIN mAcceptThreadThread[Thread-926,5,main]
    Bluetooth - 2016-02-15 10:19:30.756 - BEGIN mAcceptThreadThread[Thread-926,5,main]
    Bluetooth - 2016-02-15 10:19:30.756 - setState() 1 -> 1
    All - 2016-02-15 10:19:30.677 - start
    Bluetooth - 2016-02-15 10:19:30.577 - start
    All - 2016-02-15 10:19:30.304 - setState() 3 -> 1
    Bluetooth - 2016-02-15 10:19:30.127 - setState() 3 -> 1
    All - 2016-02-15 10:19:30.019 - Error: disconnected
    bt socket closed, read return: -1
    Bluetooth - 2016-02-15 10:19:29.913 - Error: disconnected
    bt socket closed, read return: -1
    All - 2016-02-15 10:19:28.928 - Received Message from Lenovotablet: Text: "BackupAlarm=:=08=:=53"
    All - 2016-02-15 10:19:28.887 - END mAcceptThread
    In - 2016-02-15 10:19:28.794 - Received Message from Lenovotablet: Text: "BackupAlarm=:=08=:=53"
    Bluetooth - 2016-02-15 10:19:28.579 - END mAcceptThread
    All - 2016-02-15 10:19:28.544 - BEGIN mConnectedThread
    All - 2016-02-15 10:19:28.498 - setState() 1 -> 3
    Bluetooth - 2016-02-15 10:19:28.445 - BEGIN mConnectedThread
    Bluetooth - 2016-02-15 10:19:28.441 - setState() 1 -> 3
    All - 2016-02-15 10:19:28.320 - create ConnectedThread
    Bluetooth - 2016-02-15 10:19:28.199 - create ConnectedThread
    All - 2016-02-15 10:19:28.153 - cancel Thread[AcceptThread,5,main]
    Bluetooth - 2016-02-15 10:19:28.088 - cancel Thread[AcceptThread,5,main]
    All - 2016-02-15 10:19:27.971 - connected
    Bluetooth - 2016-02-15 10:19:27.894 - connected
     
  12. skribb

    skribb Member

    Joined:
    Mar 5, 2015
    Messages:
    44
    Likes Received:
    1
    I have now tried using the wifi service instead and it has been working more reliably, however, I have been getting occasional time-out errors in the apache server. I'm thinking it could be related to Android or my connection rather than AutoRemote itself?
     

Share This Page