AutoTools Bug: Assistant profile runs when switching users

Discussion in 'AutoApps' started by tuur, Nov 26, 2018.

  1. tuur

    tuur New Member

    Joined:
    Sep 20, 2016
    Messages:
    21
    Likes Received:
    0
    The Assistant profile from the AutoTools app executes when I switch to a different user.
    I'm running Android 8.0 on a LG G6.

    I already kind of fixed it by checkin in my task if I'm currently logged in to my main user before actually performing the actions in said task. This only a partial fix because sometimes the Assistant profile activates before the profile I use to check which user is logged in. This means the task is sometimes executed fully.

    This is a minor inconvenience though, just thought I'd let you know.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Thanks for the report!

    Can you please export your profile's description (not xml) so I can take a look? Long-click the profile in Tasker->export description Thanks in advance
     
  3. tuur

    tuur New Member

    Joined:
    Sep 20, 2016
    Messages:
    21
    Likes Received:
    0
    Profile: Rebind Assistant (157)
    Event: AutoTools Assistant [ Configuration:No configuration necessary.

    This condition will trigger when you long press your home button and AutoTools is configured as the default assistant in Android Settings -> Apps -> Settings (cogwheel on top right) -> Assist App ]
    Enter: Open Sesame (158)
    A1: Launch App [ App:Sesame Data: Exclude From Recent Apps:On Always Start New Copy:Off ] If [ %OTHERUSER ~ False ]
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Thanks. I'll try to figure out what it could be!
     
: autotools, bug

Share This Page