AutoVoice Cannot connect from Google Assistant

Discussion in 'AutoApps' started by dougwzz99, Mar 10, 2019.

  1. dougwzz99

    dougwzz99 New Member

    Joined:
    Mar 10, 2019
    Messages:
    2
    Likes Received:
    0
    I can't get tasker autovoice tasks to run from google assistant. I've been using autovoice for some time and this used to work but (possibly following the latest android update to pie) seems to have stopped working.

    If I make autovoice the device assistant and invoke it directly (long press on home) and say the command then the tasker tasks work fine. If i make Google assistant the device assistant I can say 'Let me talk to autovoice' and it starts autovoice and I say the command and it appears to be accepted and I get the 'autovoice left the conversation' message, but the task doesn't run.

    I've tried unlinking and relinking Autovoice to google assistant, no change.

    Any help will be much appreciated!

    TIA.

    --doug.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    Did you try going into AutoVoice > Devices? that will make it register your device with Google Assistant.
     
  3. dougwzz99

    dougwzz99 New Member

    Joined:
    Mar 10, 2019
    Messages:
    2
    Likes Received:
    0
    Yes that was it. It came up with 'User not authenticated' once I did that it all started working again. My mistake, I thought I only had to register the device there if I wanted to send commands in from another (i.e. remote) device. Didn't realise the local device needed to be there for things to work locally.

    Thanks!
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    Glad it's working :D
     

Share This Page