AutoWeb Cannot Import APIs from Server

Discussion in 'AutoApps' started by hub_batch, May 22, 2018.

  1. hub_batch

    hub_batch New Member

    Joined:
    May 22, 2018
    Messages:
    1
    Likes Received:
    0
    Hey,

    Everytime I try to import APIs to use for AutoWeb from the server, it claims I haven't logged in, despite having to log in every time I start the app. What gives?
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    Can you please try going into the updates screen and check if you can login there? thanks!
     
  3. DartVeiga

    DartVeiga New Member

    Joined:
    Aug 3, 2018
    Messages:
    3
    Likes Received:
    0
    Hi, I have the same issue.
    I'm prompted to select Google Account. I select my own. But then a java message appears:

    "Error getting APIs from server:
    java.lang.RuntimeException:Must be signed in to import APIs from server".

    I tried clean data from all AutoApps, including Tasker, AutoInput and AutoWeb. Tried to uninstall an reinstall. Nothing seems to work. All permissions are given (I think!): Acessibility, Device Administrator, etc...

    It's a Android 6.0 Marshmallow. If you need more detail I can provide.

    Please advice.
     

    Attached Files:

  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    Seems to be a recurrent issue with Android 6, sorry. Will have to try and figure out what it could be.
     
  5. DartVeiga

    DartVeiga New Member

    Joined:
    Aug 3, 2018
    Messages:
    3
    Likes Received:
    0
    I just did a factory reset on the device and reinstalled everything. Nothing changed.

    Is there anything I could try? Or could you please provide a file to manually import Spotify plugin? For now it's the only one I intend to use.

    Um abraço e continue o seu excelente trabalho!
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    DartVeiga likes this.
  7. DartVeiga

    DartVeiga New Member

    Joined:
    Aug 3, 2018
    Messages:
    3
    Likes Received:
    0
    Thank you. It worked just fine!
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    Ok, released an update for AutoWeb that should fix this. Sorry for the delay!
     
: autoweb, auto web

Share This Page