AutoWear Can't disable Wifi on AW2.0 with Zenwatch 2

Discussion in 'AutoApps' started by tuur, Jul 21, 2017.

  1. tuur

    tuur New Member

    Joined:
    Sep 20, 2016
    Messages:
    17
    Likes Received:
    0
    Enabling wifi is no problem, but toggling or disabling it does nothing. I'm using Auto Wear to disconnect my watch when charging, so alternatively a setting to toggle airplane mode on the watch would also be very much appreciated.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,723
    Likes Received:
    671
    Thanks for the report! I'll try fixing that ASAP!
     
  3. eDs

    eDs New Member

    Joined:
    Jan 10, 2016
    Messages:
    12
    Likes Received:
    0
    Same on the urbane 2
     
  4. nmyron3983

    nmyron3983 New Member

    Joined:
    May 8, 2018
    Messages:
    2
    Likes Received:
    0
    I just joined to report that I am having a very similar issue. I created a toggle screen using AutoWear so I can easily swap things on/off. Bluetooth works great, I am able to flip it on and off without issue. However with my WiFi toggle, if I start with WiFi off I can toggle it on, but tapping the toggle again does not deactivate WiFi.

    Can I provide logging or anything that might assist with diagnosis?
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,723
    Likes Received:
    671
    Thank you for the report. Can you please let me know exactly how you're toggling it off?
     
  6. nmyron3983

    nmyron3983 New Member

    Joined:
    May 8, 2018
    Messages:
    2
    Likes Received:
    0
    Well I tried a few ways. I had great luck creating a Bluetooth toggle using the "Settings" feature to toggle the state of Bluetooth. So I did the same here, and created a button on a screen, and tied that button to a "Setting" and set it to "Toggle" the WiFi state. This will turn the WiFi on, but will not turn it off. So I then created a pair of buttons, and one "Setting" to enable WiFi, and one to "Disable" WiFi, but again the enable function worked if the WiFi was off, but the disable function did not shut off the WiFi. So I tried the Secure Settings option, and I got my watch hooked up to my laptop and gave the app the permissions suggested in AutoWear and created a secure setting that toggled ''wifi_on". This made no visible change. So I tried the two button approach, one to set the value as an integer to 0 to disable and 1 to enable. Again no change that I could see.

    I did some reading too, and from what I could find in the Android API guide, and from what it mentioned the settings lists (Global, Secure and System) are read-only values and most stated they have to be changed by the user in the settings menu. So I am not sure that approach can work at all.

    This says Secure Settings are read-only
    https://developer.android.com/reference/android/provider/Settings.Secure

    These appear to be editable via API
    https://developer.android.com/reference/android/provider/Settings.Global

    Not sure about these
    https://developer.android.com/reference/android/provider/Settings.System
     
  7. tuur

    tuur New Member

    Joined:
    Sep 20, 2016
    Messages:
    17
    Likes Received:
    0
    This doesn't appear to be fixed yet.
     
  8. Gazp

    Gazp New Member

    Joined:
    Mar 26, 2018
    Messages:
    1
    Likes Received:
    0
    Seems like this is still a problem. Enabling wifi works fine, disabling and toggling don't do anything. Ticwatch E here.
     

Share This Page