AutoInput Can't Get This to Work

Discussion in 'AutoApps' started by DonC, Apr 11, 2019.

  1. DonC

    DonC New Member

    Joined:
    Apr 11, 2019
    Messages:
    7
    Likes Received:
    0
    I created the following simple code but it does not work.
    Profile: Anon (18)
    Event: AutoInput Key [ Configuration:Keys: Volume Up
    Key Action: All ]
    Enter: Fred (5)

    Task: Fred (5)
    A1: Vibrate Pattern [ Pattern:0,4000,1000,500,1000,1000 ]

    All the phone does is make the Ringtone higher.

    I noticed in the autoinput app screen at the bottom there is a note saying "In Tasker add Action->Plugin->AutoInput to use" but I do not know what that means.

    Help...
     
    Last edited: Apr 11, 2019
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,169
    Likes Received:
    697
    Did you enable the Intercept Keys option in the main AutoInput app?
     
  3. DonC

    DonC New Member

    Joined:
    Apr 11, 2019
    Messages:
    7
    Likes Received:
    0
    Yes. Do I need to have the main AutoInput app showing as well, or is that just for settings?

    I kind of made this a simple program to test with.
     
  4. DonC

    DonC New Member

    Joined:
    Apr 11, 2019
    Messages:
    7
    Likes Received:
    0
    What does the note on the bottom of AutoInput screen mean? Not sure where in Tasker to do that. It says:
    "In Tasker add Action->Plugin->AutoInput to use"
     
  5. DonC

    DonC New Member

    Joined:
    Apr 11, 2019
    Messages:
    7
    Likes Received:
    0
    This is how to cause a task to start when pressing the volume up button - correct?
     
  6. alienclone

    alienclone New Member

    Joined:
    Feb 8, 2017
    Messages:
    26
    Likes Received:
    0
    the note is just telling you how to use Tasker to control AutoInput.
     
    Last edited: Apr 12, 2019
  7. DonC

    DonC New Member

    Joined:
    Apr 11, 2019
    Messages:
    7
    Likes Received:
    0
    How do I do that? I am new to tasker and autoinput but dont see a place to tell it about the plugin.
     
  8. DonC

    DonC New Member

    Joined:
    Apr 11, 2019
    Messages:
    7
    Likes Received:
    0
    Found the issue... Accessibility was not turned on for autoinput.

    Is there a way to toggle autoinput accessibility on and off? What steps are needed to do that. Remember I am new to tasker.
     
  9. alienclone

    alienclone New Member

    Joined:
    Feb 8, 2017
    Messages:
    26
    Likes Received:
    0
    im using the beta version of AI so im not sure which version you are using, but when i open the AI app, under the spot that tells me if accessibility is enabled or not is an option to Enable Just When Needed
     
  10. alienclone

    alienclone New Member

    Joined:
    Feb 8, 2017
    Messages:
    26
    Likes Received:
    0
    you have created tasks by now im sure. in your first post you list...

    Task: Fred (5)
    A1: Vibrate Pattern [ Pattern:0,4000,1000,500,1000,1000 ]

    A1 means Action 1, your first action in the task.

    in Tasker, when creating tasks you add Actions, this is done when you click the circle with the plus sign, this opens the Action Category screen, from there you choose "Plugin", this opens the Action Plugin Screen, from there you choose "AutoInput"

    add Action->Plugin->AutoInput
     
  11. DonC

    DonC New Member

    Joined:
    Apr 11, 2019
    Messages:
    7
    Likes Received:
    0
    Thanks... I am using the current (2.7.bf) version. It seems that if I create a task the uses the plugin->autoinput->keysuppress->disable for the key I want to use (vol up) it will do my action task as well as increasing the volume.

    I can also make the accessibility turn on by using the accessibility shortcut of the phone. (S7)
     
: Keys, Autoinput

Share This Page