Solved Chrome extension not receiving pushes after today's update (6/9)

Discussion in 'Join' started by Gaff, Jun 9, 2016.

  1. Gaff

    Gaff Member

    Joined:
    Dec 22, 2015
    Messages:
    38
    Likes Received:
    0
    Diagnostics on phone pass fine.

    Diagnostics on Chrome extension fail at:

    "Sending Push to server... Success!
    Receiving Push from server... Didn't receive push after 5 seconds: Try the steps mentioned in the FAQ here
    Receiving Push with GCM key... Didn't receive push after 5 seconds: Try the steps mentioned in the FAQ here
    Comparing GCM keys... Success!
    Testing popups... Success!"

    Tried deleting the extension and then reinstalling, but this had no effect.

    chrome://gcm-internals/ shows "GCM Connected" on the phone and "Connected" on the Chrome extension.

    Unsure what to try next...

    (Edit)

    After some testing, the issue seems to be with encryption (I was using it).

    With encryption enabled, the issues I mentioned above are present. You can push from the Chrome extension to other devices (and the pushes appear), but you cannot push from devices to the Chrome extension (the pushes vanish, and aren't delivered).

    I then disabled encryption entirely, and everything works as it should. All diagnostics pass on both ends, and all is fine. When encryption is again enabled (I used simply "1" to test), the above issues return, and the Chrome extension diagnostics fail with the error I mentioned above.

    For now it seems you need to disable encryption until this issue is resolved.

    (Edit 2)

    After further further testing, even with encryption disabled, forwarded app notifications (such as texts and emails) do not appear in the Chrome extension. Pushed tabs from a Chrome browser do, however.
     
    Last edited: Jun 9, 2016
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,973
    Likes Received:
    759
    Thank you very much! Wish all reports were as good as this one :)

    Found the issue right away, fixed it and released a new version! Should be up in about an hour!

    Thanks again!
     
  3. Gaff

    Gaff Member

    Joined:
    Dec 22, 2015
    Messages:
    38
    Likes Received:
    0
    Thanks!

    And I really wish all devs were as responsive as you.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,973
    Likes Received:
    759
    It's in my best interest to keep you happy! ;) Can you let me know if it's working? Thank you very much!
     
  5. Gaff

    Gaff Member

    Joined:
    Dec 22, 2015
    Messages:
    38
    Likes Received:
    0
    Works perfectly now. Thank you!
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,973
    Likes Received:
    759
    Awesome! :)
     
: pushes

Share This Page