AutoTools Disable and enable your lock screen at will (No Root!)

Learn how you can make your phone lock when the screen turns off only when you're not at home

  1. LarryK

    LarryK New Member

    Joined:
    Feb 20, 2019
    Messages:
    1
    Likes Received:
    0
    I have been using this on my Galaxy S8, and on a S9 and it has worked fine. My S9 just updated from Oreo to Pie, and now this isn't working any longer. It always asks for the fingerprint to unlock. The notification on the "shade" shows the correct tasker name is in use...Did something change?
     
  2. svyatk0

    svyatk0 New Member

    Joined:
    Feb 20, 2019
    Messages:
    1
    Likes Received:
    0
    Have similar problem on my Note 9 with Android 9. The task just wont work, and no error is showing as far as i can see. (see log attached)
     

    Attached Files:

  3. mk89

    mk89 New Member

    Joined:
    Oct 18, 2016
    Messages:
    7
    Likes Received:
    0
    Any progress on this? Any way to make it work like with Good lock routines on android pie ?
     
  4. Robert B

    Robert B New Member

    Joined:
    Jul 11, 2018
    Messages:
    25
    Likes Received:
    1
    Works fine on my Note 9 with Pie on it
     
  5. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    129
    Likes Received:
    1
    Something similar has happened to me as well when I upgraded to Pie. If I manually set 'lock_screen_lock_after_timeout' for anything longer than the max 30 mins listed, it resorts to immediate lock.

    Note 8
    Pie
    Standard, non-rooted ROM

    Edit: Seems if I switch to using the Custom Settings Action instead of the function in AutoTools it works, though it must be in milliseconds.
     
    Last edited: Jun 1, 2019
  6. Sluca

    Sluca New Member

    Joined:
    Sep 1, 2019
    Messages:
    2
    Likes Received:
    0
    Hi
    Could you explain more in depth how you fixed this? I also have a non-rooted Note 8 on Pie and the Android “Lock automatically” setting makes it impossible for Tasker to go beyond the 30 minute maximum. Thanks in advance!
     
  7. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    129
    Likes Received:
    1
    Not much detail here. I switched to using the Custom Setting Action in Tasker/Settings instead of from within the AT plugin.
     

Share This Page