AutoVoice Disable AutoVoice reading out of commands

Discussion in 'AutoApps' started by Reverence, Apr 21, 2018.

  1. Reverence

    Reverence New Member

    Joined:
    Apr 21, 2018
    Messages:
    6
    Likes Received:
    0
    So I've setup AutoVoice and through Google Assistant have setup some alternative phrases that will automatically translate in to "Let me talk to autovoice...", which will in turn launch AutoVoice via the Google Assistant. When it launches AutoVoice in the assistant, it reads out the text:
    "Say your autovoice command now..."
    , and then after you speak the command it reads out the text:
    "Sending command..."

    I saw there was an option to disable the toast message from being displayed; but is there an option to stop auto voice from speaking this out loud?

    I ask because I have AutoVoice launch certain tasker tasks that also speak as their first step, and AutoVoice is talking over those, so it's just not working well.

    Let me know. Thanks.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,472
    Likes Received:
    796
    AutoVoice has to respond something, but you can change it to just "ok" for example if you create a command and response in the main app -> Personal Assistant -> commands :)

    Hope this helps!
     
    kv1dr and distante like this.
  3. Pavel_K

    Pavel_K New Member

    Joined:
    Aug 5, 2020
    Messages:
    2
    Likes Received:
    0
    Hey, soory to ressurect this old post, but I have a tip and a question.

    The tip i can suggest goes as following:
    The autovoice reposnse can actually be blank. I managed to achieve this setting response in Russian (my native language). To ensure the result i also set the response to a single "ь", which is completely unreadable on it's own.
    Wether due to the fact that Russian is not supported by google home or because i set an unreadable letter as a response - but I now get a single *blup* sound, notifying that an AutoVoice command was called.

    The question I have is kind of a tricky one:
    My girlfriend used to be able to call autovoice from her IOS-device and get the silent response i set up (although I did have to log in with her Google account for AutoVoice to work).
    Now that works with the routines _i_ set up from my Android phone. However if a routine is set up from her iphone (via Google Home app) - she still gets a default 'Command sent %command%' even though a custom command is set up for her account and works if it's envoked from my routine.

    joaomgcd any idea how i can investigate this behaviour? Maybe go through some logs?

    Thanks! And again, please forgive me for necro-posting
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,472
    Likes Received:
    796
    Good tip, thanks! :)

    About the issue, just so we're clear, on her iPhone is she using a different account than what you're using on your phone?
     
  5. Pavel_K

    Pavel_K New Member

    Joined:
    Aug 5, 2020
    Messages:
    2
    Likes Received:
    0
    Hi there,
    yes, she has a standalone account on her phone, hence the need to set up the same routines on her iphone (otherwise some integrations refuse to run, namely yeelight and ihc smarthome).

    Thanks for helping me out on this one!
     
: autovoice

Share This Page