AutoTools Don't miss important notifications when unlocking screen while holding your phone

Expand your notification tray based on if you're holding your phone or not

  1. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,040
    Likes Received:
    613
    joaomgcd submitted a new AutoApps project:

    Don't miss important notifications when unlocking screen while holding your phone - Expand your notification tray based on if you're holding your phone or not

    Read more about this project...
     
    Bosser likes this.
  2. Bosser

    Bosser New Member

    Joined:
    Mar 11, 2015
    Messages:
    4
    Likes Received:
    0
    Hi,

    Thanks for this guide!

    I'm trying to change the profile to make it notify me with a vibration when I've missed a notification from specific apps while my screen is off.

    I've changed the profile condition to screen off.

    And I've changed the expand status bar in vibration in the task.

    However it doesn't seem to work really well :(
    Are there some other values I need to change?

    Thanks in advance!

    PS: Thank you for another amazing plugin!!!
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,040
    Likes Received:
    613
    Glad you're enjoying it! :)

    Can you please export your profile's description (not xml) so I can take a look? Long-click the profile in Tasker->export description Thanks in advance
     
    Bosser likes this.
  4. Bosser

    Bosser New Member

    Joined:
    Mar 11, 2015
    Messages:
    4
    Likes Received:
    0
    Thank you for your answer! ! !

    Here you go :)

    Profile: Trillen Gemiste Melding (107)
    State: Display State [ Is:Off ]
    Event: AutoNotification Intercept [ Configuration:Event Behaviour: true
    Has Reply Action: false
    Notification Apps: Textra,Telegram,WeMail,Agenda
    Get All Fields : false
    Get Internal Actions: false
    Get Internal Actions Big: false ]
    Enter: Trillen Gemiste Melding (147)
    A1: AutoTools Sensors [ Configuration:Sensor Number: 15
    Convert Orientation: true Timeout (Seconds):60 ]
    A2: Flash [ Text:%atsensor2 Long:Off ]
    A3: If [ %atsensor2 > 0 & %atsensor2 < 70 ]
    A4: AutoNotification Query [ Configuration:Notification Apps: Telegram,Textra,WeMail,Agenda
    Use Regex: false
    Has Reply Action: false
    Get All Fields : false Timeout (Seconds):20 ]
    A5: Vibrate [ Time:200 ] If [ %antitle(#) > 0 ]
    A6: End If
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,040
    Likes Received:
    613
    What exactly isn't working about that?
     
  6. Bosser

    Bosser New Member

    Joined:
    Mar 11, 2015
    Messages:
    4
    Likes Received:
    0
    It only works like 30% of the time, very oftenly I only get a vibration when putting the phone back down instead of when picking it up
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,040
    Likes Received:
    613
    So you want to pick up your phone while the screen is still off and have it vibrate still with the screen off?
     
    Bosser likes this.
  8. Bosser

    Bosser New Member

    Joined:
    Mar 11, 2015
    Messages:
    4
    Likes Received:
    0
    Yes that's what I was trying to create :)
    A bit like the missed call and text vibration from Samsung :)

    Thank you for your answers!
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,040
    Likes Received:
    613
    Then you can't use the AutoNotification Event condition :) You want it to vibrate, not when you receive a notification, but when a notification is present, right?

    You should use 3 conditions in this case:
    1. Screen off
    2. AutoNotification Intercept State (not event) condition
    3. Screen not facing up (built in tasker condition)
    I think that should work :)
     
  10. isriey

    isriey New Member

    Joined:
    Mar 1, 2017
    Messages:
    1
    Likes Received:
    1
    Hi!
    Thanks for the wonderful tutorial.
    I have a setback while creating the task. When I try to get data from the TYPE_GAME_ROTATION_VECTOR sensor, I get an error with code
    Error: 1857733900
    Couldn't get values from sensor

    I am on latest Auto Tools Beta.
    Kindly help.
    [​IMG]
     
    Laural Hill likes this.
  11. eDs

    eDs New Member

    Joined:
    Jan 10, 2016
    Messages:
    12
    Likes Received:
    0
    im always getting 90 doesnt matter how i hold the phone or if its down on my desk. lg g5
     
  12. Thiago Talma

    Thiago Talma New Member

    Joined:
    Jan 25, 2017
    Messages:
    2
    Likes Received:
    0
    Same here.

    @joaomgcd what's happening?
     
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,040
    Likes Received:
    613
    Does it help if you rotate the phone a lot first? Maybe it's not calibrated...
     
    Thiago Talma likes this.
  14. troy0619

    troy0619 New Member

    Joined:
    Jun 13, 2018
    Messages:
    2
    Likes Received:
    0
    having some issues myself; maybe an update is needed.
     
  15. Thiago Talma

    Thiago Talma New Member

    Joined:
    Jan 25, 2017
    Messages:
    2
    Likes Received:
    0
    Thanks, @joaomgcd
     
  16. Dario Paganini

    Dario Paganini New Member

    Joined:
    Jul 11, 2018
    Messages:
    1
    Likes Received:
    0
    Hi @joaomgcd !
    I have problems reading the number 09 sensor (gravity sensor).
    It give me sometime the error :
    Error: 1857733900
    Couldn't get values from sensor

    Or more frequently the error:
    Error: Null
    And on the status in the upper bar of Android :
    AutoTools action error
    Couldn't get values from sensor

    If I enable the "use unreliable values" option, then some not right values are given for the three axis for the first call, then the next values (always not reliable) are given after a minute or so. In poor words: the values are not given and the timeout expires without the sensor is giving values. I tried a 60 seconds timeout and also 1, 5, 10, 15, 30 seconds timeout without luck.
    I tried also to recalibrate but no luck.
    I also used an app to show the sensors values, and under the GRAVITY sensor this app gives correct values and updated many times in a second, so the sensor is working prefectly.
    How can I solve this ? I'm also curious if this problem is only mine or others have the same behaviour on reading this GRAVITY sensor. Many thanks !
     
    Last edited: Jul 11, 2018
  17. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    7,040
    Likes Received:
    613
    Unfortunately I don't have a way to solve it, sorry! AutoTools simply gets the values from the system and reports to you if it can't get them :(
     

Share This Page