Multiple AutoApps Editing an autoapps profile clears the variable names field

Discussion in 'AutoApps' started by obscurereference, Jun 19, 2018.

  1. obscurereference

    obscurereference New Member

    Joined:
    Mar 6, 2015
    Messages:
    24
    Likes Received:
    1
    I have a few autoapps command event based profiles in Tasker. They use the 'variable names' field to define variable names. Whenever I edit one of them (even without looking at the variable names field), the variable names get silently deleted, breaking the resulting task.
    It looks as though the variable names field isn't getting populated on the edit screen.

    Thanks
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,337
    Likes Received:
    784
    Hi. Thanks for the report. Does that always happen 100% of the time? I can't reproduce that issue on my devices...
     
  3. obscurereference

    obscurereference New Member

    Joined:
    Mar 6, 2015
    Messages:
    24
    Likes Received:
    1
    That's odd, yes it happens 100% of the time. I'm on a moto g5 plus (stock rom, unrooted). To reproduce:

    In Tasker create a profile with an auto apps command event
    Enter something in the command filter and variable fields
    Save changes and check all fields have been saved
    Go back and edit the profile - command filter remains filled in, variable field is blank

    Don't worry too much if you can't fix it, I'll just have to be cautious when editing these profiles
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,337
    Likes Received:
    784
    So, like this? It never fails to work for me :(
     
  5. obscurereference

    obscurereference New Member

    Joined:
    Mar 6, 2015
    Messages:
    24
    Likes Received:
    1
    I'm afraid so, exactly like that! See the screenshots below (this is a quicker way to reproduce the bug, but following your YouTube video produces the same result) ...

    1. Open a profile with the variable field filled in Screenshot_20180626-102347.png 2. Press the edit button
    Screenshot_20180626-102356.png
    3. Press the back button and hey presto! The variable is gone
    Screenshot_20180626-102400.png
    This is on a moto g5 plus. I have a kindle fire tablet around somewhere, I'll dig it out, update it and see if it works on that
     
: autoapps, bug

Share This Page