AutoRemote Error getting personal URL

Discussion in 'AutoApps' started by NMemon, Mar 18, 2015.

  1. NMemon

    NMemon New Member

    Joined:
    Mar 18, 2015
    Messages:
    11
    Likes Received:
    1
    I just factory reset my Nexus 7 tablet today, and now I get this message once I've entered the device name. I've tried reinstalling autoremote but no go. Since I'm unable to get the personal URL, I can't register other android devices on the Nexus.

    Any help would be appreciated.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    If you enter the logs, does it say anything more there? any detail?
     
  3. NMemon

    NMemon New Member

    Joined:
    Mar 18, 2015
    Messages:
    11
    Likes Received:
    1
    If I enable system logs, untick and tick the active in settings then the following is reported in logs:
    Generating new url
    device unregistered from GCM. won't receive messages.
    getting device key
    device key is here
    generating new url
    updating personal url on server
    update my url on autoremote server
    generating new url

    However the same error then appears on the home screen, 'Error getting personal URL. Make sure you have internet......'

    Uninstalling and reinstalling Autoremote, same error, but nothing in logs, as system logs aren't selected.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    NMemon likes this.
  5. NMemon

    NMemon New Member

    Joined:
    Mar 18, 2015
    Messages:
    11
    Likes Received:
    1
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    It's not visible. It's in a special "App folder" that apps have access to. Glad it works!
     
  7. NMemon

    NMemon New Member

    Joined:
    Mar 18, 2015
    Messages:
    11
    Likes Received:
    1
    Alright, many thanks for your help :)
     
  8. NMemon

    NMemon New Member

    Joined:
    Mar 18, 2015
    Messages:
    11
    Likes Received:
    1
    Now registration is failing on all devices, Log message, 'URL is not valid'
     
  9. NMemon

    NMemon New Member

    Joined:
    Mar 18, 2015
    Messages:
    11
    Likes Received:
    1
    I have also installed your new version on one other device (Nexus 4) along with the blighted Nexus 7. Works on the N4, but same problem on the tablet re registration, i.e. invalid URL as above
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    NMemon likes this.
  11. NMemon

    NMemon New Member

    Joined:
    Mar 18, 2015
    Messages:
    11
    Likes Received:
    1
  12. JinKanzaki

    JinKanzaki New Member

    Joined:
    Mar 20, 2015
    Messages:
    1
    Likes Received:
    0
    Sooooo, I'm not sure this is the correct place to ask, but my issue seems to be similar enough.

    In EventGhost I downloaded the required plugin and entered the device name and the URL, but in the field where it should create the key it just says "invalid URL"

    However, when I put the URL in my browser it works, do you have any idea how to fix this?


    If this is the wrong place to ask, sorry, please tell me where to go >.<
     
  13. NMemon

    NMemon New Member

    Joined:
    Mar 18, 2015
    Messages:
    11
    Likes Received:
    1
    You should create a new thread with the title "invalid URL". Joao Dias, creator of Autoremote is also the admin of this forum, would pick it up and solve it for you. He is very helpful, so rest assured you'll be in good hands.
     
  14. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    @JinKanzaki are you using the short url? You shouldn't input the long url...
     
  15. Upean

    Upean New Member

    Joined:
    Apr 7, 2018
    Messages:
    1
    Likes Received:
    0

    Attached Files:

  16. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Can you confirm that you have an internet connection?
     
  17. AZJedi

    AZJedi New Member

    Joined:
    Apr 17, 2018
    Messages:
    3
    Likes Received:
    0
    I'm getting exactly the same error. I am using an old Verizon Galaxy s4. The internet is connected and working on other apps. I have autoremote running and working on another Verizon Galaxy S4.
     
  18. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Thanks for the report. Does it help if you clear app data and try again?
     
  19. AndryeBar

    AndryeBar New Member

    Joined:
    Apr 17, 2018
    Messages:
    2
    Likes Received:
    0
    Google shut down it's "goo.gl" url shortener service, so AutoRemote app can't create personal short url and show error message, but recieve notifications (if you somehow know the API key)
     
  20. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Yeah, but they said it would continue working for a year for existing apps :( Now I have to fix this in a hurry...
     
    Gustavo Ruiz Bonino likes this.

Share This Page