AutoRemote error "Package file is invalid" when installing AutoRemote

Discussion in 'AutoApps' started by cah65, Aug 24, 2015.

  1. cah65

    cah65 New Member

    Joined:
    Aug 23, 2015
    Messages:
    2
    Likes Received:
    0
    Hello
    Days ago, I bougth autoremote from google play.I can't install it because I've got an error: "Package file is invalid"
    I tried to install autoremote lite and I've got the same error.
    My phone is Samsung S2 Android 2.3.1 and I've uninstalled and installed many times google playstore as well as cancelling and restoring my google account without results
    Where can I buy again the autoremote outside from google play?

    thank you
     
  2. Daniel D

    Daniel D Member

    Joined:
    Feb 11, 2015
    Messages:
    127
    Likes Received:
    11
    Giving the old Android version you're running, it is a possibility that AutoRemote is incompatible with Gingerbread. I'm not 100% sure, though.
    Only Joao can give you a clear answer.
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    I haven't tried installing it on Gingerbread for a long time now. Does it give any reason why it says it's invalid?
     
  4. cah65

    cah65 New Member

    Joined:
    Aug 23, 2015
    Messages:
    2
    Likes Received:
    0
    no reason given!
    only appears on screen the error ; package file is invalid.
    I am desperate!
     
  5. Speshal

    Speshal New Member

    Joined:
    Sep 16, 2015
    Messages:
    9
    Likes Received:
    0
    I am getting the same error, I had Autoremote previously installed on my phone and had to do a factory reset, when I went to reinstall Autoremote I get the the "package file is invalid" message.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    I have now tried to run this on an Android 2.3.7 device and indeed it doesn't install. This happens due to bugs in the earlier Android versions where apps could not be too complex or they would fail to install. I'll have to remove support for Android versions lower than 4.0 for now, sorry. I'll try to see if I can find a way to get it working again. Sorry!
     
  7. Speshal

    Speshal New Member

    Joined:
    Sep 16, 2015
    Messages:
    9
    Likes Received:
    0
    Any news?
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Nope, sorry. It's going to have to be incompatible for now. :( I'll update the google play description to reflect this. Sorry for the trouble.
     
  9. donutz

    donutz New Member

    Joined:
    Feb 13, 2016
    Messages:
    1
    Likes Received:
    0
    Is there a way to get an older version of the app that would install on an old Gingerbread phone? Would it function correctly?

    I have an old Droid X running android 2.3.4 that gives an "ERROR CODE : -11" after it downloads and attempts to install from the play store.
     
    Last edited: Dec 15, 2016
  10. Artimis

    Artimis New Member

    Joined:
    Dec 18, 2016
    Messages:
    13
    Likes Received:
    0
    I wouldn't mind a link to the older version as well. Auto remote has been working great for me on all my 4.1+ devices but I have a Droid X, Droid 2, Droid 3, and Motoactive that I need to install this on but can't due to this error.
    If the incompatibility was introduced with IFTT integration, is there a link to the version prior? I don't use that feature anyway.

    Thanks.
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Unfortunately I no longer have the old versions sorry :( Wish Google would keep them so I could download them for you.
     
: error

Share This Page