AutoLocation Geofences on Android 8 Oreo not working

Discussion in 'AutoApps' started by Stokesy, Sep 20, 2017.

  1. Flackburst

    Flackburst New Member

    Joined:
    Oct 11, 2018
    Messages:
    4
    Likes Received:
    0
    joaomgcd, I downloaded the version from the link in post 19. What version should it show? Current version in Google play is 1.2.1 and version I have downloaded and installed is also 1.2.1.
    This is not working for me on Samsung Galaxy S7 on Verizon with Oreo 8.0.0.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    Yes, that's correct, I didn't update the version number... What exactly is not working for you?
     
  3. Flackburst

    Flackburst New Member

    Joined:
    Oct 11, 2018
    Messages:
    4
    Likes Received:
    0
    It doesn't respond when I enter a geofence area. I check and it take quite some time before even indicates I am in the area.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    802
    For some locations that seems to be a problem, yes. What I found is that if you turn on the geofence and let it be on for a few days, Google suddenly will start "learning" more about it and then start triggering it better.

    For example, a few weeks ago I tested a home geofence on a new phone and it wouldn't trigger no matter what. I left it on so I could keep testing and after a while it simply started working...

    If you don't want to wait for this "optimization" I suggest you use the location monitor in AutoLocation and enable the option to let the location monitor help the geofence monitor in AutoLocation -> Advanced.

    Hope this helps.
     
  5. Flackburst

    Flackburst New Member

    Joined:
    Oct 11, 2018
    Messages:
    4
    Likes Received:
    0
    joaomgcd, Thanks, I will give it a try with the new version. And thanks for all your work making Tasker better!
     

Share This Page