AutoVoice Help changing "Ok Google" hotword with AutoVoice on Nexus 6p

Discussion in 'AutoApps' started by tdxloki, Feb 9, 2016.

  1. tdxloki

    tdxloki New Member

    Feb 9, 2016
    Likes Received:
    I followed the instructions on this archived post with my nexus 6p.

    How to change the trigger word for google now.

    I cannot seem to get it working, so I thought I would ask for some help.

    I have tried systematically switching on and off options in AutoVoice, e.g., "run in foreground" and "alternative method", and substituting other apps in place of "VoiceSearchActivity" in Tasker, e.g., "DspHotwordVoiceSearchActivity", but no luck.

    The hardware and up-to-date Google Now app in my nexus 6p should be compatible with this method.

    Has anyone with a nexus 6p, or anyone with Marshmallow got this working?

    I am using AutoVoice (v 2.0.46) with AutoVoice Pro Unlock.

  2. joaomgcd

    joaomgcd Administrator Staff Member

    Feb 3, 2015
    Likes Received:
    What part exactly isn't working for you? Thanks!
  3. tdxloki

    tdxloki New Member

    Feb 9, 2016
    Likes Received:
    Thanks for your help!!
    Following the posted guide in the link did not produce the desired effect on my phone which was to change the "Ok Google" hotword to "computer."
    There are two parts specifically where my phone does not respond.
    1. When setting an AutoVoice Recognized->Matching Options->Speak Filter a Google microphone window opens but my phone does not hear my voice. (I then manually enter my Command Filter word, i.e., "computer")
    2. After setting the event profile using the AutoVoice Recognized plugin in Tasker and task to launch "VoiceSearchActivity", noting happens.

    Here are my AutoVoice and phone settings.
    Google Now Integration (enabled)
    Nothing else is selected in the Google Now Integration submenu - my phone is not rooted so I am not trying to use the XPosed Module
    My phone and google account are setup in Devices (probably not necessary for this task)
    General Setting Menu - all default
    AutoVoice Continuous (enabled)
    Stream to Mute - set to Media.
    Advanced Menu
    Nothing selected (No Hot Phrase entered.)

    Nexus 6P
    Settings->Accessibility AutoVoice Google Now Integration = On
    Settings->Google->Search & Now->Voice->"Ok Google" detection
    From the Google app (enabled) - Say "Ok Google" to start a voice search from the Google app or any Home screen in the Google Now Launcher
    Always on (enabled) - Responds to your voice. Works wehether the screen is on or off
    "Ok Google" Voice Model - the voice model is trained to my voice saying "Ok Google"
    Default language is English (US)

    These are the steps I follow:
    1. First go to the main autovoice app and set the control continuous option to on.
    2. Make a new profile by clicking '+' and select event > plugin > autovoice > recognized now click the pencil icon near configuration, select "speak command" and say whatever you want to trigger the event, then select the tick mark icon to save the profile. (when I speak the command nothing a google microphone screen flashes but it does not accept my voice command so I enter it manually.)
    3. Make a new task to link the profile to and name it anything you want to.
    4. Open the task, select '+' and select App > Launch App > long press "Google", scroll down and select "VoiceSearchActivity". Select back on the top right to save the action.

    Tasker is running, AutoVoice Continuous is running. I say "computer" and nothing happens.

    I have tried switching "Ok Google" detection on/off. I have tried rebooting my phone. I have tried "Run In Foreground" on/off, "Alternative Method" on/off. I am not sure what steps to take next but I suspect that I am not setting something correctly in Tasker.
    Last edited: Feb 11, 2016

Share This Page