AutoWeb Issue using the Sunrise/Sunset api

Discussion in 'AutoApps' started by scotts, Apr 26, 2019.

  1. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    124
    Likes Received:
    1
    There appears to be some calculation issue in using this api.

    Using the attached screenshot as a guide...in testing my related Task, the result is a good 4hrs behind the api's test city of Chicago, IL, USA.

    Task description...

    Sunrise/Sunset Test (194)
    A1: AutoWeb Web Service [ Configuration:API: Sunrise/Sunset
    API Action: Get Sunrise/Sunset times
    Lat: 41.878113
    Lng: -87.629799
    Date: today
    Formatted Date: 1 Timeout (Seconds):30 ]
    A2: Flash [ Text:Sunrise: %sunrise
    Sunset: %sunset Long:On ]
    [​IMG]

    Scott on Note8 Tapatalk
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,234
    Likes Received:
    707
    Sorry the values returned from the API are not changed by AutoWeb so it must be an issue with the API. Maybe try the DarkSky API?
     
  3. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    124
    Likes Received:
    1
    I discovered the issue... times are returned in UTC. I was then going to request an offset in the app, but realize, I need to convert to seconds for Tasker use anyhow.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,234
    Likes Received:
    707
    Glad you got it!
     

Share This Page