AutoContacts Issues with Getting Contact Photo

Discussion in 'AutoApps' started by Stupifier, Apr 17, 2015.

  1. Stupifier

    Stupifier Member

    Joined:
    Mar 10, 2015
    Messages:
    147
    Likes Received:
    6
    I'm trying to get the Contact Picture for a contact. Every time I try, it retrieves a completely wrong picture or sometimes even no photo at all. It is very strange.....

    I stepped through AutoContacts to get the exact %acid number for the contact picture I want. Then I used the AutoContacts Details action, gave it the %acid number, and asked it to Get Picture. Tried with/without Full Size......I also tried different contacts. All have Contact pictures in my Contacts App.....but AutoContacts is not retrieving the picture correctly.

    Any help on this?

    Update: I also tried using the "Number From URI" Method instead of Contact ID. I was able to get the Contact URI using AutoShare. Still didn't work. Super weird.

    Update 2: Interesting result. So all my contacts on my Contacts app are stored through my Google Account. So I thought I'd try storing a test contact on my actual Phone (instead of just saving the contact to my Google Account). After I did that and gave the contact a contact photo.....I tested AutoContacts with it....and it worked, but only for that contact which is stored on the Phone....which is super lame!

    Did you know of this behavior? Seems AutoContacts can only Get Contact Pictures for contacts which you tell the Contact App to keep on your phone. If you save your contacts to your Google Account (like most people do), AutoContacts seems unable to retrieve the Contact Photo.....Yet it is able to retrieve everything else....just not the photo.
     
    Last edited: Apr 17, 2015
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,495
    Likes Received:
    720
    That's weird. I can't replicate that behaviour on my phone. I never store contacts locally, always through Google, but contact pictures are retrieved correctly. Can you please export a small test task where you do this so I can check it out? (description, not xml).
    Thanks!
     
  3. Stupifier

    Stupifier Member

    Joined:
    Mar 10, 2015
    Messages:
    147
    Likes Received:
    6
    Below is just the test task I created... Just pulls %acid from a contact I have (this functions correctly), then attempts to use that very same %acid to pull the contact photo and display it as a pop-up image (not working, image does not display).

    Code (Text):

    Test2 (50)
    A1: Wait [ MS:0 Seconds:1 Minutes:0 Hours:0 Days:0 ]
    A2: AutoContacts [ Configuration:Refresh: true
    Contact Name or Nickname: Hailey
    Name as Nickname: true Package:com.joaomgcd.autocontacts Name:AutoContacts Timeout (Seconds):1000 ]
    A3: Flash [ Text:%acid Long:Off ]
    A4: Variable Set [ Name:%test To:%acid Do Maths:Off Append:Off ]
    A5: AutoContacts Details [ Configuration:Contact Id: %test
    Get Picture: true
    Full size: true Package:com.joaomgcd.autocontacts Name:AutoContacts Details Timeout (Seconds):1000 ]
    A6: Popup [ Title: Text:%acid Background Image:%acpicturefile Layout:Popup Timeout (Seconds):5 Show Over Keyguard:On ]
     
     
    Last edited: Apr 20, 2015
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,495
    Likes Received:
    720
    huh, weird. I know it was working before, but I just tried it and it didn't work!
    Luckily I found another way to do it. :) Can you try using this version of the app please? Please refresh your contacts from the main app prior to running the task.
    Thanks for the report!
     
  5. Stupifier

    Stupifier Member

    Joined:
    Mar 10, 2015
    Messages:
    147
    Likes Received:
    6
    YES! Success......Works flawlessly.
    Thank you for fixing this. Dunno what the problem was, but you figured it out on your end. Can I keep this updated version of AutoContacts? I'll still receive updates from the Play Store just fine too, right?
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,495
    Likes Received:
    720
    Yes, you can keep that one :) No problem. Glad it's fixed!
     
  7. Stupifier

    Stupifier Member

    Joined:
    Mar 10, 2015
    Messages:
    147
    Likes Received:
    6
    Yay, I feel proud....I caught a bug!
     

Share This Page